IBM Support

How to logoff from a Citrix server (for example to forcibly end a hung/stuck controller session)

Troubleshooting


Problem

Customer is deploying controller via Citrix. An user finds a problem inside their controller session (for example it has become frozen / stuck / hung). They would like to forcibly end their session (on the Citrix server) themeselves (without needing to contact their I.T. department's Citrix administrators who could do it for them.

How can the user logoff (fully terminate / end) their Citrix session themselves?

Symptom

User is experiencing a problem with their Citrix server (possibly caused by something crashing in the past). User would like to reset their Citrix session, so that they can log on with a brand-new (fresh) session. However, they would like to be able to do this without needing to contact their I.T. department.

Cause

On the Citrix server, there is a Windows session (running under the user's Windows user account) which still has some processes running (for example, perhaps CCR.EXE or EXCEL.EXE).

  • If the user reboots their laptop, that Citrix session will still be running (although in a 'disconnected' state), for example:

Environment

Controller is being delivered to users via Citrix.

  • This is an extremely popular method to deploy the controller client to remote users.

Resolving The Problem

This technote specifically relates to two methods which should work in almost all Citrix environments and two alertnative solutions.

Method #1  - Logoff by using Citrix Connection Center.


Steps:
The exact steps will vary slight depending on your environment (for example what version of Citrix you are using). The following steps are based on Citrix client version 4.2.1.


1. Make sure that you have launched the relevant Citrix application first

  • For example, typically a user would log on to a Citrix website, and then click the icon (probably called something similar to 'IBM Cognos controller') which launches controller
  • In other words, makes sure that you have connected to your frozen / stuck / crashed Citrix session first (before continuing)


2. Then look at the 'systray' (the icons to the left of the clock) and locate the relevant Citrix client icon

  • Different Citrix client versions will have different-looking icons.
  • For example, here is what the Citrix Receiver (4.2.1) icon looks like:


3. Right-click on 'Citrix Receiver' and choose 'Connection Center':


4. Click to highlight your Citrix server:


5. Click "Log Off".

======================================================

Method #2  - Use the Citrix hot key 'Ctrl+ F1' to bring up 'Windows Sign-in'

Perform the following steps:
1. Make sure that your Citrix application (in our case either controller or Excel) is visibly running on your screen (and highlighted/selected/in-focus)

2. On your keyboard, tap the following keys simultaneously: Ctrl + F1

  • The following screen should appear:

image-20180903160727-1

3. Click 'Sign Out'

======================================================

Method #3 (rarely necessary) - Logoff by using a combination of methods #1 & #2

This method is rarely necessary. It is required if both are true:

(a) Clicking 'Logoff' does nothing (therefore method #1 will not work)

(b) You cannot reach the controller client, in order to use Ctrl + F1 (therefore method #2 will not work)


Steps:
The exact steps will vary slight depending on your environment (for example what version of Citrix you are using). The following steps are based on "Citrix Workspace" client (May 2019):
1. Make sure that you have launched the relevant Citrix application first

  • For example, typically a user would log on to a Citrix website, and then click on an icon (probably called something similar to 'IBM Cognos controller') which launches controller
  • In other words, makes sure that you have connected to your frozen / stuck / crashed Citrix session first (before continuing)


2. Then look at the 'systray' (the icons to the left of the clock) and locate the relevant Citrix client icon

  • Different Citrix client versions will have different-looking icons.
  • For example, here is what the Citrix Workspace icon looks like:

image-20190508090118-1
3. Right-click on 'Citrix Workspace' and choose 'Connection Center':

image-20190508090155-2
4. Click to highlight your Citrix server:

image-20190508090234-3
5. Click "Full Screen"

6. You will now see a Window appear, that may (in some circumstances) be completely black.

  • On your keyboard, tap the following keys simultaneously:     Ctrl + F1
  • The following screen should appear:

image-20190508090419-4

7. Click 'Sign Out'

======================================================

Method #4

Have the user that has a process that is stuck to sign back into the Citrix Storefront using their main URL and select the log-off option from here.
 

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Document Information

Modified date:
08 April 2022

UID

swg21978164