Question & Answer
Question
How do you enable verbose logging in Intellishare to diagnose SPNEGO authentication issues?
Cause
To troubleshoot Intellishare authentication issues, it is sometimes useful to enable verbose logging to gather more information on the problem.
Enabling this verbose logging can create a very large number of log files, especially if the JBoss server is re-started on a regular basis. Ensure that your JBoss server has adequate free disk space before enabling verbose logging, and be sure to disable it once you have resolved the issue.
Answer
To enable verbose logging, perform the following:
1. Modify jboss-log4j.xml in your JBoss configuration set for Intellishare (this is typically jboss-5.1.0.GA\server\intellishare\conf\). Add the following two logging modules directly beneath the 'com.i2group' and 'org.hibernate' logging modules:
<category name="com.i2group.intellishare.loginmodule" additivity="false">
<priority value="TRACE" />
<appender-ref ref="CONSOLE" />
<appender-ref ref="ROOTLOG" />
</category>
<category name="org.jboss.security">
<priority value="TRACE"/>
<appender-ref ref="ROOTLOG" />
</category>
2. Add the following options to the bat file used to start your JBoss server:
-Dsun.security.spnego.debug=true -Dsun.security.krb5.debug=true
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Document Information
Modified date:
19 February 2022
UID
swg21695442