Troubleshooting
Problem
When I click the "Print to PDF" action from the Publish tab, I receive the following error:
Unable to export PDF. Please select a paper size in Page Setup.

When I check the paper size in the Page Setup, there are no choices.

Cause
You might have a default printer that is not available. The error can happen when you move your system from the office where you used Network printers, to your home office.
Diagnosing The Problem
From your system search bar type in "Printers & scanners" to check whether there is an error associated with your default printer. The printer marked as "Default" is your default printer. Here is an example of a printer that cannot be reached:

Resolving The Problem
Change your default printer to a different printer. Select a printer from the list and click "Manage".

In the Manage your device window, click "Set as default". The Printer status changes to "Default". Close the window.

After you restart Analyst's Notebook, the "Print to PDF" action prompts for the location to save the PDF file. The error no longer appears.
Document Location
Worldwide
[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"ARM Category":[{"code":"a8m50000000Cb2bAAC","label":"i2 Analyst's Notebook and other i2 software->Chart->Publishing"}],"ARM Case Number":"TS004206432","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
Product Synonym
ANB; ANBP
Was this topic helpful?
Document Information
Modified date:
01 October 2020
UID
ibm16339751