Troubleshooting
Problem
From the Internet Explorer browser, I log in to the Intelligence Portal, or access it from i2 Analyst's notebook to view the data from the Analysis Repository. When I do an action such as Browse, I get an error:

"The repository has failed to respond. Contact your system administrator."
Clicking the "More info" button gives the following details:
The repository has failed to respond. Contact your system administrator.i2.Apollo.Common.Exceptions.ServerNotFoundException
Server could not be found.
System.ServiceModel.CommunicationException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.50918.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result)
at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.SearchServiceClientChannel.EndSearch(IAsyncResult result)
at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.i2.Apollo.Services.Internal.Search.AutoGen.SearchService.EndSearch(IAsyncResult result)
at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.i2.Apollo.Services.SearchService.ISearchServiceInternals.EndSearch(IAsyncResult result)
at i2.Apollo.Services.SearchService.SearchServiceFacade.CompleteAndMarshalSearch(ISearchServiceInternals client, IAsyncResult resultToken)
at i2.Apollo.Services.AsynchronousCallCompleter`2.GetResponse(IAsyncResult asyncResult, TResult& successResult, Exception& failureException)
System.Net.WebException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.50918.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state)
at System.Net.Browser.BrowserHttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelAsyncRequest.CompleteGetResponse(IAsyncResult result)
System.Net.WebException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.50918.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer at System.Net.Browser.BrowserHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult)
at System.Net.Browser.BrowserHttpWebRequest.<>c__DisplayClassa.<EndGetResponse>b__9(Object sendState)
at System.Net.Browser.AsyncHelper.<>c__DisplayClass4.<BeginOnUI>b__1(Object sendState)
Cause
Your i2 Enterprise Insight Analysis or i2 Analyze system is configured with an HTTP Server. When you specified the url, you added the port number as you noticed in the console.log. However the url with the port number is used internally when the HTTP Server communicates with the application in Liberty. Users should access the HTTP Server url without the port number.
Resolving The Problem
Remove the port number from the url, and log in again.
http://<hostname>/apollo
Document Location
Worldwide
[{"Type":"SW","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXVTH","label":"i2 Analyze"},"ARM Category":[{"code":"a8m0z000000cwjSAAQ","label":"i2 Enterprise Insight Analysis->AR"}],"ARM Case Number":"TS005585943","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"4.3.0"},{"Type":"SW","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXVXZ","label":"IBM i2 Enterprise Insight Analysis"},"ARM Category":[{"code":"a8m0z000000cwjSAAQ","label":"i2 Enterprise Insight Analysis->AR"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"2.3.0"}]
Product Synonym
EIA; onyx; AR
Was this topic helpful?
Document Information
Modified date:
18 May 2021
UID
ibm16453373