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How do I Resolve error code = 123, Return Code: -1, Return Code 9616, Return Code 1001 Errors Found in the Content Manager Enterprise Edition Resource Manager Log Files?

Question & Answer


Question

How do I resolve the following errors found in the Content Manager Enterprise Edition (Content Manager) resource manager log?

ICMRM:ERROR 2019-06-14 23:00:59.621000 context:async-delete
[icmrm_RMTimerManager.Alarm Pool : 0]
- com.ibm.mm.icmrm.exceptions.RMSMSException: Error reported from system call to storage at \\server.company.com\RMShareDrive:
GetVolumeInformation function call, last error code = 123 - The filename, directory name, or volume label syntax is incorrect.
, Return Code: -1, Return Code: 9616, Return Code: 1001 - performAction(RMDeleteController.java:123)
com.ibm.mm.icmrm.exceptions.RMSMSException: Error reported from system call to storage at \\server.company.com\RMShareDrive:
GetVolumeInformation function call, last error code = 123 - The filename, directory name, or volume label syntax is incorrect.
, Return Code: -1, Return Code: 9616, Return Code: 1001

Cause

When using a CIFS device as a volume for the Content Manager resource manager, the device mount point must contain a closing backslash character ( \ ).

Answer

  1. Connect to the resource manager database. For example:
    db2 connect to rmdb user rmadmin using password
    Where rmdb is the resource manager database name; rmadmin is the resource manager database administrator ID; and, password is the password for the resource manager database administrator ID. Change these values to match those of your particular environment as needed.
  2. Query the rmvolumes table to get current volume definitions:
    db2 "select * from rmvolumes"
  3. Check the output to confirm that one of the volumes has the mount point defined exactly as referenced in the resource manager log. For example, the VOL_MOUNTPOINT for one volume is defined as \\server.company.com\RMShareDrive and has no trailing \ character. Sample output for the affected volume referenced above:
    (output truncated for readability)

    VOL_VOLUMEID VOL_SERIAL  VOL_STGCLASSID VOL_ATTRIBUTES VOL_MEDIATYPE VOL_SERVERID VOL_SIZE VOL_FREESPACE VOL_STATUS VOL_THRESHOLD VOL_NUMBUCKETS VOL_REFERENCEDDATE VOL_LOGICALNAME VOL_MOUNTPOINT VOL_PATH VOL_OFFLINELOC VOL_AGGREGATESIZE    VOL_AGGREGATESTATUS VOL_HIGHTHRESHOLD VOL_LOWTHRESHOLD
    -------------------------------------------------------------------------------------------------------------------------         
    20          -1             16              0             0            0          51169456128           2366464000 A                     99          10000 01/01/2019   UNCDrive \\server.company.com\RMShareDrive 0                   0                99               60
  4. Note that the actual value for VOL_MOUNTPOINT above is \\server.company.com\RMShareDrive and has no trailing backslash
  5. Update the rmvolumes table to include the trailing backslash character using the VOL_VOLUMEID, VOL_LOGICALNAME, and VOL_MOUNTPOINT values captured from the SQL command above. For example:
    db2 "update rmvolumes set VOL_MOUNTPOINT = '\\server.company.com\RMShareDrive\' where VOL_VOLUMEID = 20 and VOL_LOGICALNAME = 'UNCDrive' and VOL_MOUNTPOINT='\\server.company.com\RMShareDrive' "
  6. Commit the update:
    db2 commit
  7. Restart the resource manager WebSphere application server in Windows Services to pick up the change
  8. Confirm that the error is no longer seen in the resource manager log

Related Information

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSAHQR","label":"IBM Z System Automation"},"Component":"Resource manager","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5 fix pack 6","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
08 October 2019

UID

ibm10887797