Question & Answer
Question
Sometimes need to confirm if the an agent in Incomplete status is reporting the correct UUID (ie. same as what VMWare knows it by)
Cause
Sometimes the UUID can get out of sync (eg. rebuilding vm image, etc).
The symptom may be that VM guest shows as Incomplete status and the TLM_VM_########-####-####-####-############
does NOT match the UUID that VMWare server has for this VM guest.
Answer
Login to vSphere VMWare client GUI, click on the Host icon, then right click on any column header and select the UUID column to be displayed with each of the VM Guests
eg.

[{"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Business Unit":{"code":"BU008","label":"Security"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.2.2;7.5;9.0;9.0.1;9.1","Edition":"","Line of Business":{"code":"LOB15","label":"Integration"}}]
Historical Number
PMR 56454;379;000
Document Information
Modified date:
10 October 2019
UID
swg21682150