IBM Support

How to determine firmware level

Question & Answer


Question

How to check HMC compatibility Matrix with frame firmware.

Cause

Performing an HMC version upgrade without checking the managed system compatibility will cause an upgrade failure.

Answer

1 - First on the HMC run the following command:

#lslic -m "Managed System" -F ecnumber activated_level

NOTE: If You don't know Your Managed System name, You can find at the top by running command #vtmenu.

2 - After running the above command the output should be something like "01AL730 152".

3 - You are going to take that output but with removing the first 2 digits and putting ( _ ) sign before the last 3 digits,

Example: "01AL730 152" after removing the first 2 digits and putting ( _ ) before the last 2 digits it'll be like that
"AL730_152".

4 - Take that final combination "AL730_152" and check it's compatibility from the following link:
https://www-945.ibm.com/support/fixcentral/main/transform?xml=https://download.boulder.ibm.com/ibmdl/pub/software/server/firmware/sfw_fixSupportedCombos.xml&title=Supported+Combinations

If the managed system firmware level is not compatible with the desired HMC version,Call the next level of IBM Hardware Support. to upgrade firmware level.

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Document Information

Modified date:
17 June 2018

UID

isg3T1025886