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How to control the encoding of CSV files when using the Export Searched Documents function in Watson Content Analytics.

Question & Answer


Question

I use the Export Searched Documents function in Watson Content Analytics v3.5 to export documents in CSV format. How can I change the encoding of the exported CSV files?

Cause

The default encoding of CSV file is "utf-8" when you export searched documents in CSV format. There is no such setting you can change on the Administration console in configuring Options for Export Searched Documents.

Answer

This can be done manually by modifying a configuration file.

  1. Go to ES_NODE_ROOT/master_config/<collection_id>.indexservice/export directory
  2. Back up searched_csv_export_mapping.xml
  3. Open searched_csv_export_mapping.xml with a XML editor
    There is an element
    <property name="encode" value="utf-8" />
    Instead of "utf-8", you can use other character set name. This one will be passed to java OutputStreamWriter. For instance, SJIS is valid for Japanese.
  4. Restart exporter session by esadmin command
    esadmin <collection_id>.exporter restart

    Note: If you change the CSV export configuration, the file will be replaced with new one, therefore you need to modify the configuration file again.

[{"Product":{"code":"SS5RWK","label":"Content Analytics with Enterprise Search"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"3.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21695529