IBM Support

How to configure Red Hat Enterprise Linux 8 to run Rational ClearCase

Question & Answer


Question

How do you configure a Red Hat Enterprise Linux 8 system to install and run IBM® Rational ClearCase?

Cause

ClearCase® requires some system packages that might not be installed on your Red Hat Enterprise Linux 8 system. These packages must be installed before you install and configure ClearCase.

Answer

The set of packages that must be installed depends on both the system architecture (X86_64, PPC64LE, S390X) and the ClearCase® version (32-bit or 64-bit). The system's installer is able to detect if a package is already installed on the system, so it will not be reinstalled.
List of packages needed for ClearCase 32-bit on x86:
  • base-x (YUM group)
  • libstdc++.i686
  • libXmu.i686
  • libacl.i686
  • ncurses-libs.i686
  • ncurses-compat-libs.i686
  • motif.i686
  • xterm
  • libxcrypt.i686
  • libmount.i686
  • libgcc.i686
  • libnsl.i686
  • libXdmcp.i686
  • libXdmcp
  • libnsl
  • psmisc
  • elfutils-libelf-devel
  • make
  • Note: Red Hat 8.5 and higher include libxcrypt.x86_64, so you do not need xcrypt. More information is provided by Red Hat at https://access.redhat.com/errata/RHBA-2021:4371
CTE, on 32-bit ClearCase®, requires:
  • gtk2.i686
  • libXtst.i686
A command line start of CTE will report missing packages that do not effect use of CTE:
  • adwaita-gtk2-theme.i686
  • adwaita-gtk2-theme
  • adwaita-icon-theme.noarch
  • libcanberra-gtk2.i686
  • libcanberra-gtk2
  • PackageKit-gtk3-module.i686
  • PackageKit-gtk3-module
To install the packages, open a terminal and type the following 5 command lines:
$ sudo yum -y group install base-x
$ sudo yum -y install libstdc++.i686 libXmu.i686 libacl.i686 ncurses-libs.i686 ncurses-compat-libs.i686 motif.i686 xterm libmount.i686 libgcc.i686 libnsl.i686 libXdmcp.i686 libxcrypt.i686 libXdmcp libnsl psmisc elfutils-libelf-devel make
$ sudo yum -y install gtk2.i686 libXtst.i686
$ sudo yum -y install adwaita-gtk2-theme.i686 adwaita-gtk2-theme adwaita-icon-theme.noarch libcanberra-gtk2.i686 libcanberra-gtk2 
$ sudo yum -y install PackageKit-gtk3-module.i686 PackageKit-gtk3-module
List of packages needed for ClearCase 64-bit on x86:
  • base-x (YUM group)
  • libstdc++
  • libXmu
  • libacl
  • ncurses-libs
  • ncurses-compat-libs
  • motif
  • xterm
  • libmount
  • libXdmcp
  • libxcrypt
  • libnsl
  • psmisc
  • elfutils-libelf-devel
  • make
CTE also requires:
  • gtk2
  • libXtst
A command line start of CTE will report missing packages that do not effect use of CTE:
  • adwaita-gtk2-theme
  • adwaita-icon-theme.noarch
  • libcanberra-gtk2
  • PackageKit-gtk3-module
To install the packages, open a terminal and type the following 4 command lines:
$ sudo yum -y group install base-x
$ sudo yum -y install libstdc++ libXmu ncurses-libs ncurses-compat-libs motif xterm libmount libXdmcp libxcrypt libnsl psmisc elfutils-libelf-devel make
$ sudo yum -y install gtk2 libXtst
$ sudo yum -y install adwaita-gtk2-theme adwaita-icon-theme.noarch libcanberra-gtk2 PackageKit-gtk3-module
List of packages needed for ClearCase on PPC64LE
  • base-x (YUM group)
  • libstdc++
  • libXmu
  • libacl
  • ncurses-libs
  • ncurses-compat-libs
  • motif
  • xterm
  • libmount
  • libXdmcp
  • libxcrypt
  • libnsl
  • psmisc
  • elfutils-libelf-devel
  • make
CTE also requires:
  • gtk2
  • libXtst
A command line start of CTE will report missing packages that do not effect use of CTE:
  • adwaita-gtk2-theme
  • adwaita-icon-theme.noarch
  • libcanberra-gtk2
  • PackageKit-gtk3-module
To install the packages, open a terminal and type the following 4 command lines:
$ sudo yum -y group install base-x
$ sudo yum -y install libstdc++ libXmu ncurses-libs ncurses-compat-libs motif xterm libmount libXdmcp libxcrypt libnsl psmisc elfutils-libelf-devel make
$ sudo yum -y install gtk2 libXtst
$ sudo yum -y install adwaita-gtk2-theme adwaita-icon-theme.noarch libcanberra-gtk2 PackageKit-gtk3-module
 List of packages needed for ClearCase on S390X
  • base-x (YUM group)
  • libstdc++
  • libXmu
  • libacl
  • ncurses-libs
  • ncurses-compat-libs
  • motif
  • xterm
  • kernel-devel
  • libmount
  • libXdmcp
  • libxcrypt
  • libnsl
  • psmisc
  • elfutils-libelf-devel
  • make
To install the packages, open a terminal and type the following command lines:
$ sudo yum -y group install base-x
$ sudo yum -y install libstdc++ libXmu ncurses-libs ncurses-compat-libs motif xterm kernel-devel libmount libXdmcp libxcrypt libnsl psmisc elfutils-libelf-devel make

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSSH27","label":"Rational ClearCase"},"ARM Category":[{"code":"a8m50000000L0i5AAC","label":"ClearCase"}],"ARM Case Number":"","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.0.0;10.0.1;9.0.2;9.1.0;and future releases"}]

Document Information

Modified date:
03 October 2023

UID

ibm10887639