IBM Support

How to change the path to the debug log (lmgrd.log) for Rational License Key Server

Question & Answer


Question

How do you change the path to the debug log (lmgrd.log) for Rational License Key Server?

Cause

Attempts to change the path to the debug log file on LMTOOLS (IBM Rational License Tools) may result in the error The license file / license Path does not exist where specified. and you cannot save the changes.

Answer

You can change the path to the lmgrd.log file as below.

Disclaimer

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986


  1. Go to Start > Run, type in Regedit and click OK

  2. Navigate to the following registry hive:

    HKEY_LOCAL_MACHINE\SOFTWARE\Flexlm License Manager\Flexlm License Manager


  3. Create/Modify the string value key called LMGRD_LOG_FILE and set the value data to the full path of the debug log file.

    For example:

    C:\Program Files\IBM\RationalRLKS\common\lmgrd.log


  4. Restart the Rational License Key Server

  5. Once the license server is started, it will start writing information into the log file.
[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
Rational License Key Server

Software version:
Version Independent

Operating system(s):
Windows

Document number:
329145

Modified date:
16 June 2018

UID

swg21132793