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How can I use the Audit Configuration Wizard to enable, export and import Case Foundation Case Analyzer reporting settings of Case Manager solution properties?

Question & Answer


Question

How can I use the Audit Configuration Wizard to enable, export and import Case Foundation Case Analyzer reporting settings of Case Manager solution properties?

Cause

The purpose of this tech note is to provide detailed guidance with sample screenshots how to use the new Audit Configuration Wizard in Content Platform Engine 5.2.1.

Please note: You must be a system administrator to apply the following procedures. Familiarity with the following is required:

  • Administration Console for Content Platform Engine (ACCE);
  • Case Manager administration client;
  • General administration skills for the Content Platform Engine, Case Manager and Case Analyzer.

You can click on many of the images in this tech note to see their enlarged versions.

Answer

This technote covers four main functions provided by the Audit Configuration Wizard:

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There are two additional administrative tasks required for successful auditing and Case Analyzer reporting:
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Typical Scenarios


This section is a high-level overview of the procedures and the order they have to be used in typical scenarios.
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Scenario 1: Enable auditing of a solution property and configure Case Analyzer reporting
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Scenario 2: Import an Audit Configuration Manifest and configure Case Analyzer reporting
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The sections below have detailed instructions for each procedure marked with a bullet point above.
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Main Functions Provided by the Audit Configuration Wizard

Create an Audit Configuration Manifest to enable property auditing


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First, in Case Manager, make sure the properties are defined in the solution, added to a case type, and the solution is deployed.
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  1. Log into the Case manager administration client. (http://[case manager server name]:[port]/navigator/?desktop=icmadmin
  2. In the navigation pane, click on the node for the design or staging object store. This will open a tab for the design or staging object store on the right-hand side. The navigation pane will display the tree structure for the design or staging object store.
  3. In the navigation pane, click on the Solutions node. The solutions will be listed on the right.
  4. On the right, click on the name of the solution.
  5. Click the Actions button.
  6. Select the Manage -> Audit Configuration command.
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  7. Select the Create an audit configuration radio button, then click the Next button.
  8. Enter a name for the audit manifest in the Audit manifest name edit box, then click the Next button. On the sample screenshot below, we are creating an audit manifest called CATestAuditManifest.
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  9. Click the Add button.
  10. Make sure the following values are selected in the drop-down list boxes:
    Object type: Case
    Object name: The case type for which you want to configure auditing. On the sample screenshot after the next step below, the case type is called CATestCaseType.
    Task name: No Task Selected
  11. Move the solution properties you want to audit from the Available Properties list to the Selected Properties list, then click OK.
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  12. On the next screen, click the Next button.
  13. Check the Apply audit configuration check box. This will enable the Apply button.
  14. Click the Apply button.
  15. Wait for the Success message, When the Success message is displayed, you can optionally check the log generated for enabling auditing. Then, click the Close button.
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NOTE: the Audit Configuration Manifest that you have just created can be saved and applied later, or imported for the same solution in other Case Manager environments.

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Export Audit Configurations


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  1. Log into the Case manager administration client. (http://[case manager server name]:[port]/navigator/?desktop=icmadmin
  2. In the navigation pane, click on the node for the design or staging object store. This will open a tab for the design or staging object store on the right-hand side. The navigation pane will display the tree structure for the design or staging object store.
  3. In the navigation pane, click on the Solutions node. The solutions will be listed on the right.
  4. On the right, click on the name of the solution.
  5. Click the Actions button.
  6. Select the Export -> Audit Configuration command.
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  7. On the next screen, make a note of the output file in the Audit configuration package file name edit box. Optionally, you can edit the file name.
  8. The auditing settings configured for the solution are listed under Available configurations. Click on the configuration you want to export. On the sample screen below, that configuration is called CATestAuditManifest. This will enable the Next button.
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  9. Click the Next button.
  10. On the next screen, confirm your settings and click the Finish button.
  11. Wait for the message 'The audit configuration were successfully exported.' Then click the Download and Close button. The audit manifest export file will be downloaded by the browser.

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Import an Audit Configuration Manifest


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  1. Log into the Case manager administration client. (http://[case manager server name]:[port]/navigator/?desktop=icmadmin
  2. In the navigation pane, click on the node for the design or staging object store. This will open a tab for the design or staging object store on the right-hand side. The navigation pane will display the tree structure for the design or staging object store.
  3. In the navigation pane, click on the Solutions node. The solutions will be listed on the right.
  4. On the right, click on the name of the solution. In the sample screen below, we clicked on the solution called CATestSolution.
  5. Click on the Import button.
  6. Select the Import Audit Configuration command.
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  7. Click on the Browse button next to "Audit configuration package file name".
  8. Browse to the audit configuration package file, and select it.
  9. Back on the Import Audit Configuration tab in the Case Manager administration client, click the Next button.
  10. On the next screen, confirm your settings and click the Finish button.
  11. Wait for the message 'Audit configuration package successfully imported.' Then click the Close button.
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Note: after these steps, you have to apply the auditing settings you have just imported. Otherwise, they will not take effect.

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Apply Audit Settings Contained in an Audit Configuration Manifest


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  1. Log into the Case manager administration client. (http://[case manager server name]:[port]/navigator/?desktop=icmadmin
  2. Make sure the Solutions tab of the design or staging object store is displayed in the Case Manager administration client, and the solution name is highlighted.
  3. Click the Actions button.
  4. Select the Manage -> Audit Configuration command.
  5. Select the 'Edit an audit configuration' radio button.
  6. Scroll down and click on the name of the audit configuration you imported. On the sample screen below, that configuration is CATestAuditmanifest. This will enable the Next button.
  7. Click on the Next button.
  8. On the next two screens, click on the Next button.
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  9. On the 'Apply audit configuration' screen, click the check box next to 'Apply audit configuration'. This will enable the Apply button.
  10. Click the Apply button.
  11. Wait for the message 'Success'. Then click the Close button.
  12. Log out of the Case Manager administration client.

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Additional Administrative Tasks:

Ensure Audit Logging is Enabled for the Target Object Store


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  1. Log into ACCE.
  2. Navigate to Object Stores -> [Target Object Store] and click on the [Target Object Store] node in the navigation pane.
  3. Click on the General tab on the right-hand side.
  4. Scroll down to find the Enable auditing property.
  5. If the Enable auditing property is set to False, then change it to Yes, and click the Save button.
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Add the Solution Property to the Case Analyzer Configuration


  1. Start the Case Analyzer Process Task Manager by running the captm.bat (Windows) or captm.sh (UNIX/LINUX) script. The script is located in the [Content Platform Engine installation directory]/tools/PE directory.
  2. Expand the top-level [P8 domain name] node down to the Data Fields node in the navigation pane.
  3. Right-click the Data Fields node and select New.
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  4. In the Data Field Wizard dialog, select the 'Use Content Engine field as a template' option and click Next.
  5. On the next screen, click on the drop-down arrow for the Field Name box, and select the solution property you want to add to the Case Analyzer configuration. Click Next.
  • Optionally, you can specify a different name to be displayed for this property on the Case Analyzer reports in the Unique Name edit box.
  • NOTE: the field name you enter in the Unique Name edit box must be unique in the Case Analyzer store.

  • 1. On the next screen, choose if you want to add a Dimension or a Measure. Click Next.
  • NOTE: the Measure option is greyed out if the type of the property is not appropriate for a Measure field in Case Analyzer.

  • 1. If OLAP is enabled for Case Analyzer: on the next screen, choose if you want to add the property to both Case Analyzer cubes and fact tables, or to the fact tables only.
    2. If you chose to add the property to both Case Analyzer cubes and fact tables: on the next screen, select the Case Analyzer cubes you want to add the property to. Then click Finish.
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After successfully adding the property, the Case Analyzer Process Task Manager will display the new Case Analyzer fields. The message pane at the bottom of the Process Task Manager will show success messages. For example, the screenshot below shows that we added an integer property called testCAIntProp as a measure, and a string property called testCAStringProp as a dimension (TGS2 is the solution prefix in Case Manager. By default, the solution prefix is part of the data field name in Case Analyzer):
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[{"Product":{"code":"SSCTJ4","label":"IBM Case Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Case Manager Admin Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"5.2.1","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21695992