Question & Answer
Question
How to boot PowerVM Virtual I/O Server (VIOS) to maintenance mode using the Hardware Management Console (HMC) GUI and the optical drive on the IBM Power System.
For assistance booting VIOS to maintenance mode using AIX NIM Server, refer to Using NIM to boot into Maintenance Mode or contact your local AIX NIM Support Representative.
Cause
A VIOS might need to be booted into a maintenance mode in situations when the VIOS is inaccessible. For example, the VIOS is failing to boot or padmin's password was lost and needs to be reset.
Answer
PREREQUISITES
1. VIOS bootable media
- Note 1: In order to boot a VIOS partition into maintenance, a VIOS bootable image is required. The bootable image needs to match the VIOS release installed on disk. For example, if the VIOS partition is running ioslevel 3.1.4.x, use a 3.1.4.x bootable image. Failure to use appropriate bootable media may lead to library or symbol resolution errors after the rootvg volume group is imported and a shell is started. Examples of VIOS bootable media include:
a. VIOS Installation DVD * See Note 2- This includes installation media that came with the IBM Power system or VIOS Installation ISO image burned to media. VIOS installation software is available in the Entitled Systems Support (ESS) website. For details see How to Obtain Installation Software for PowerVM Virtual I/O Server
2. The following procedure uses the optical device in the Power System. The optical drive on the IBM Power System must be allocated to the VIOS partition in question before continuing. For assistance with this step, contact your local HMC Support Representative.
Note 2: Power9 and newer Power Systems hardware no longer include a built-in optical DVD drive. An external USB-attached drive may be required. It is recommended to use an external USB-attached thumb drive or an external USB DVD drive.
3. IMPORTANT: A VIOS reboot will impact all clients hosted by the VIOS being rebooted. To minimize the impact to the clients, you must ensure all clients' network and storage is redundant though a second VIOS. If clients are served by a single VIOS, a maintenance window needs to be scheduled to shutdown the clients before rebooting the VIOS.
PROCEDURE
1. Load the bootable media (DVD 1 of 2) in the optical device.
2. Shut down the VIOS partition
- Log in to the HMC GUI as hscroot. In left navigation:
> Click System Management
> Servers
> Select Managed System name. This option lists the partition names on the right navigation.
> Select VIOS partition name
> Click Tasks
> Operations
> Shutdown
> Select Operating System
3. Activate the VIOS partition to the SMS Main menu.
- > Select VIOS partition name
> Click Tasks
> Operations
> Activate
> Profile
> Click Advanced > Change 'Boot mode' to SMS > Click OK
> Select 'Open a terminal window or console session' > Click OKExample of SMS Main Menu

- > option 5. Select Boot Options
> option 2. Configure Boot Device Order
> option 6. Display Current Setting. This option shows the Current Boot Sequence. Take note of this information. (If the VIOS has SAN-attached storage, it may take a few minutes to scan the fibre channel adapters).
> Hit ESC key to go back to the previous menu
> select option 7. Restore Default Setting to set the optical device as the first boot device, as shown below:
- > Hit x key to exit SMS
> Select option 1. Yes. This causes the boot process to read from the bootable DVD image, denoted by the 'boot device' path ending with ...bootfile.exe as shows below:
6. Select the system console
7. Select the language
8. Select option 3. Start Maintenance Mode for System Recovery
9. Select option 1 Access a Root Volume Group
10. Type 0 (zero) and press Enter to continue

- The next screen will present the volume group ID(s) to select from.
11. Select the appropriate option for your VIOS rootvg volume group. The following screen will list the Volume Group ID and logical volumes, i.e.
- 1) Access this Volume Group and start a shell
- This option attempts to import the VIOS rootvg volume group and mount VIOS core filesystems as shown below:
This option it typically used to do VIOS maintenance or recovery procedures that are not possible to be done through a normal padmin login. For example, padmin's password was lost and needs to be reset padmin or the VIOS partition is failing to boot.
- This option can be use in situations where VIOS rootvg filesystem integrity is questionable and filesystem check (fsck) may need to be performed.
- This option attempts to import the VIOS rootvg volume group and mount VIOS core filesystems as shown below:
[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m50000000L0KDAA0","label":"PowerVM VIOS-\u003EBOOT"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"3.1.1;3.1.2;3.1.3"}]
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Document Information
Modified date:
05 July 2024
UID
isg3T1026837




