Troubleshooting
Problem
Host Disk Failure / SAS Controller Warning
Symptom
1. nzhw -issues output shows something similar like these:
$ nzhw -issues
Description HW ID Location Role State
------------- ----- -------------------------- ------ -------
HostDisk 1333 rack1.host1.hostDisk5 Failed Down
SASController 1336 rack1.host1.SASController0 Active Warning
2. /nz/kit/log/eventmgr/eventmgr.log shows something similar like these:
NPS system <Hostname> - host disk 1333 Needs attention. System initiated.
location:upper host, 5th host disk
error string:state is warning
devSerial:xxxxx
event source:System initiated
NPS system <Hostname> - SAS Controller 1336 Needs attention. System initiated.
location:upper host, SAS Controller
error string:Host disk(s) has become critical 1 from7
devSerial:xxxxx
event source:System initiated
Cause
The most common reason for a hard disk failure is wear-and-tear.
Diagnosing The Problem
From the output of 'nzhw -issues':
$ nzhw -issues
Description HW ID Location Role State
------------- ----- -------------------------- ------ -------
HostDisk 1333 rack1.host1.hostDisk5 Failed Down
SASController 1336 rack1.host1.SASController0 Active Warning
The following are the important things to remember:
rack1.host1 = this refers to HA1 or host 1 that is located in rack 1. If it is a single-rack system, this is the upper host
hostDisk5 = this pertains to hard disk in slot 4
Resolving The Problem
Please contact IBM PDA Netezza Support.
Kindly submit the following
As nz user:
1. nzstats
2. output of 'nzhw -issues'
As ROOT user:
1. /opt/nz-hwsupport/hts/install_files/IBM/mega_check.pl -a
2. dmidecode -t1
If item #1 cannot be executed, it means that the 'Hardware Tool' is not yet installed.
Please kindly download and install the Hardware Tool and execute the command again.
A. Download
This tool can be obtained in the Fix Central site.
Link: http://www-933.ibm.com/support/fixcentral/
Select Product Group->Information Management->IBM Netezza Tools -> HWSUPPORT_X
*** Get always the latest version. ***
-> Browse for fixes -> Select the newest fix pack -> Download the file in .tar.gz
B. Installation Instructions
Unpack this file and run the hw-install.pl script to install the hardware tools.
(Please download and install the latest one)
# tar -zxvf nz-hwsupport-tf-V8.1-20130124.tar.gz
# cd nz-hwsupport-tf-V8.1-20130124
# ./hw-install.pl
Please run again mega_check.pl once installed.
To run mega_check properly some packages must be installed. (Lib_Utils and MegaCli)
# cd /opt/nz-hwsupport/hts/install_files/IBM
# rpm -Uvh Lib_Utils-1.00-09.noarch.rpm
# rpm -Uvh MegaCli-8.04.08-1.noarch.rpm
[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Host","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
17 October 2019
UID
swg21983831