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Getting error while logging in to RTM Web Console - You don't have permission to access /rtm/ on this server

Troubleshooting


Problem

Getting error while logging in to RTM Web Console - You don't have permission to access /rtm/ on this server, because of php module not loaded for httpd configuration

Symptom

In /var/log/httpd/error_log, getting the following error:

Thu Jul 20 15:24:38.710185 2017] [autoindex:error] [pid 8023] [client 172.18.151.18:50094] AH01276: Cannot serve directory /opt/cacti/: No matching DirectoryIndex (index.html) found, and server-generated directory index forbidden by Options directive

Cause

It could be because the php module is not loaded for httpd

The conf files under /etc/httpd/conf/conf.d/ need to be included in httpd.conf

Diagnosing The Problem

In /etc/httpd/conf/httpd.conf, check the following line:
##IncludeOptional conf.d/*.conf

Resolving The Problem

In case it is commented out, uncomment it as follows:
IncludeOptional conf.d/*.conf

# Restart httpd for this change to take effect:
# service httpd restart

Try logging in to the web console again, it should work this time

[{"Product":{"code":"SSVMSD","label":"Platform RTM"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSZT2D","label":"IBM Spectrum LSF RTM"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
Platform RTM

Software version:
Version Independent

Document number:
631691

Modified date:
30 August 2019

UID

isg3T1025555

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