Question & Answer
Question
Tivoli Common Reporting is unavailable, while checking the cogserver.log: Getting error: ERRORCODE=-4214, SQLSTATE=28000 User ID or password invalid in the Cognos log. How do I solve this?
Cause
Inconsistent Cognos configuration.
Answer
Please follow these steps:
Go to: /opt/IBM/JazzSM/reporting/cognos/bin64
./tcr_cogconfig.sh
A GUI will appear.
Under data access -> Content manager -> IBM DB2 content store.
Here you have the details to your DB2 including the user and password please check the details an re-enter them to be sure they are correct. Make sure that DB exists and it's connectable via the db2 client.
After you finish entering the details right click IBM DB2 content store and hit TEST. If things are green, you should be good to go if not double check things again including login in with the user via the Db2 cli VS the DB you want to use.
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Product Synonym
Monitoring, Reporting, TCR,IT
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Document Information
More support for:
Tivoli Common Reporting TCR
Software version:
All Versions
Operating system(s):
Linux
Document number:
6189513
Modified date:
14 April 2020
UID
ibm16189513
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