Troubleshooting
Problem
When running the following command to purge all FD tables for a project, e.g. Test1
./IAAdmin.sh -user isadmin -password temp4now -deleteFrequencyDistribution -projectName Test1 -columnName xxxxx.fyre.ibm.com::::
and after the command completed, you observed the generated FD tables not deleted completely
Symptom
You can observed the following error messages in the WAS log:
0000028f SorcererServi E CDIIA0001E: TableManagementServiceBridge.java:1438 Failed to drop reference table - [jcc][t4][102][10040][3.71.22] Batch failure. The batch was submitted, but at least one exception occurred on an individual member of the batch.
Use getNextException() to retrieve the exceptions for specific batched elements. ERRORCODE=-4229, SQLSTATE=null
and observed the following error messages in db2dialog.log:
.02.25.338628-420 I31064563E602 LEVEL: Error
PID : 495687 TID : 139905460070144 PROC : db2sysc 0
INSTANCE: db2inst1 NODE : 000 DB : IADB
APPHDL : 0-28733 APPID: 9.30.111.31.60246.180719015829
AUTHID : IAUSER HOSTNAME: ug-per-11.svl.ibm.com
EDUID : 51568 EDUNAME: db2agent (IADB) 0
FUNCTION: DB2 UDB, data protection services, sqlpWriteLR, probe:6680
MESSAGE : ZRC=0x85100009=-2062548983=SQLP_NOSPACE
"Log File has reached its saturation point"
DIA8309C Log file was full.
Cause
From the db2 log we could see message "Log File has reached its saturation point" DIA8309C Log file was full. which is caused by the log file is full
Resolving The Problem
Increase the log file size by the following commands:
db2 update database cfg for IADB using LOGFILSIZ 10000
then restart db2 instance.
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Document Information
Modified date:
30 August 2018
UID
ibm10729855