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Flexnet error (-18,327:10054 ""): License server system does not support this feature

Troubleshooting


Problem

Flexnet error (-18,327:10054 "") after replacing the new license key for Rational application

Cause

License file fail to get updated due to lack of license server restart

Environment

Microsoft Windows & Unix

Diagnosing The Problem

Check for the license log error as given in the title and the license feature generating this error from log.

Resolving The Problem

This error is most likely to occur when the license manager is not restarted after a license file replacement. Usually a license reread is done to make the changes to a license file effective,but at certain times just copying the license file in an existing path or a new path would not be effective until a license server restart is done. Hence we must exercise to stop and restart the license manager.

On Microsoft Windows:

  1. Open LMTOOLS utility by navigating to the Rational License Server from the Microsoft Windows Start menu or go to Start -> Run and type 'lmtools' (without quotes).
  2. Once LMTOOLS interface is open. Click the 'Config Services' tab.
  3. Click the Browse button next to the 'Path to the license file' box, and browse/confirm the path to the folder containing your license file.
  4. Select the file and click Open.
  5. Click the 'Start/Stop/Reread' tab, saving the changes when prompted.
  6. Click Stop Server. It shall say 'Stopping Server' , give it few seconds to refresh the ports
  7. Now click 'Start Server' button to find the status at the bottom of this window to display 'Server Start Successful'.
  8. Now Click on 'Re-read license file' button to make the changes effective.

    Check the license service to ensure it has started running as follows
  9. Click 'Server Status' tab.
  10. Click 'Perform Status Enquiry' button to check the license server status.

    Note :If the startup has failed, check the license.dat file for errors and omissions. Double-check your file with the original, sent from IBM. There is
    also a license.log file in the installation directory, where all actions concerning the IBM Rational License Server are logged. This file is created
    in the location you specified when you installed the license server.

    In case there are any issues with Step 6/7/8, please contact Rational Client Support for assistance with the error message from 'Server Status' Tab.

On Unix:
  1. Go into the Rational directory where the Rational License Server is installed.
  2. To reread the license file to avoid using lmutil lmreread command as the result might not be correct. Instead, restart the license server using the following
    commands:

    lmutil lmdown -c <license_file_path>
    lmgrd -c <license_file_path> -l <license_log_path> -local
  3. Check the status as follows:
    lmutil lmstat -c <license_file_path>>

[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"FLEXlm","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21499302