Troubleshooting
Problem
Attempts to open an IBM Rational product even after successfully importing License Keys results in the error "FLEXlm -15 Cannot connect to the license server".
Symptom
The full error message is as follows:
FLEXlm -15 Cannot connect to the license server
If a Server Status Enquiry is performed it shows that the license server is down.
Cause
This error is often the result of no path being defined to the license file or the incorrect path to the license path is being used.
Resolving The Problem
To resolve this error, perform the following:
- Open the License Tools
- Access the Config Services tab
- Using the Browse button next to the Path to the license file, navigate to the license file.
For example:
If you have permanent keys browse to:
C:\Program Files\Rational\Common\rational_server_perm.dat
If you have temporary keys browse to:
C:\Program Files\Rational\Common\rational_server_temp.dat
Also, if you have to point both permanent and temporary keys on the license server installed on Windows you may apply the following steps:
This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986 |
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- Open Registry editor
- Navigate to HKEY_LOCAL_MACHINE > SOFTWARE > FLEXlm License Manager
- Click the expand button
- Choose FLEXlm License Manager
- Towards the right pane choose License
- Right click to select Modify
- You may then add the complete path of the temporary floating key as shown below:
C:\Program Files\IBM\RationalRLKS\common\rational_server_perm.dat;C:\Program Files\IBM\RationalRLKS\common\rational_server_temp.dat
Note: This is default path for Rational License Server v 8.x
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Document Information
Modified date:
16 June 2018
UID
swg21255670