IBM Support

FlashSystem Code Recommendations

Preventive Service Planning


Abstract

FlashSystem Code Recommendations

Content

The recommendations below are to assist clients in implementing a code update strategy. Generally, clients should upgrade to the highest recommended code stream available to obtain the latest fixes and features. Clients should not upgrade to minimum code levels. Systems do not have to upgrade if they are at or above the minimum code level.
For a customized recommendation, which takes into account business upgrade windows, length of time since last update, decommission plans, etc., clients may require assistance from local support teams. When notified of a new release, IBM recommends evaluating the need to upgrade by reviewing the release notes and the recommended code levels on this web page. The word "must", in the notes below, refers to code resolving specific problems for a targeted subset of FlashSystem systems and is communicated via My Notifications to clients.
For FlashSystem 5x00, 7200, 9100 & 9200 code recommendations go to https://www.ibm.com/support/pages/node/690527
Version matrix
FlashSystem Controller Version Configuration Minimum Level Recommended "Go To" Level Latest Level
FlashSystem V9000 V9000 8.3.x with AE3
(See Notes 1 & 2)
8.3.0.1/1.6.1.2
[Dec 2019]/[May 2020]
8.3.1.7/1.6.1.4
[Apr 2022] /[Oct 2021]
8.3.1.7/1.6.1.4
[Apr 2022] /[Oct 2021]
V9000 8.2.x with AE3
(See Note 3)
8.2.1.9 / 1.5.2.7
[Feb 2020] / [Apr 2020]
8.2.1.14/1.6.1.4
[Oct 2021] / [Oct 2021]
8.2.1.15/1.6.1.4
[Mar 2022] / Oct 2021]
V9000 8.2.x with AE2 8.2.1.9
[Feb 2020]
8.2.1.14
[Oct 2021]
8.2.1.15
[Mar 2022]
V9000 8.1.x with AE3 Move to recommended level in Release 8.2.x V9000 8.1.x with AE2
V9000 8.1.x with AE2 Move to recommended level in Release 8.2.x V9000 8.1.x with AE2
V9000 7.8.x with AE2 7.8.1.11
[Dec 2019]
7.8.1.13
[Apr 2021]
7.8.1.14
[Oct 2021]
V9000 7.7.x or below with AE2 Move to recommended level in Release 7.8.x
FlashSystem 900
900 1.6.x
(See Note 4)
1.6.1.0
[Jun 2019]
1.6.1.4
[Oct 2021]
1.6.1.4
[Oct 2021]
900 1.5.x
(See Note 4)
1.5.2.7
[Apr 2020]
1.5.2.9
[Apr 2021]
1.5.2.10
[Oct 2021]
900 1.4.x Move to recommended level in Release 1.5
900 1.3.x Move to recommended level in Release 1.5
900 1.2.x Move to recommended level in Release 1.5
  • Note 1: FlashSystem V9000 model AE2 or AC2 is not supported on 8.3.x
  • Note 2: Only move to 8.3.x if you desire any of the new 8.3.x features.
  • Note 3: If using Data Reduction Pools at 8.2.x.x, 8.2.1.9 is the minimum level.
  • Note 4: Only move to 1.6.1.x if you desire any of the new 1.6.x features.

[{"Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"STKMQB","label":"IBM FlashSystem 900"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent"},{"Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"STKMQV","label":"IBM FlashSystem V9000"},"ARM Category":[{"code":"","label":""}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent"}]

Document Information

Modified date:
14 September 2022

UID

ssg1S1009645