IBM Support

The FlashCopy Manager wizard fails to register the client acceptor service

Troubleshooting


Problem

The Tivoli Storage FlashCopy Manager Management Console stand-alone configuration wizard fails to register the client acceptor service with the following error: Unable to start Client Acceptor

Symptom

The client acceptor service cannot be started when the FlashCopy Manager stand-alone wizard is running, so the service is not registered when wizard fails. The Windows service panel does not show this service.

Cause

The msvcr100.dll is not properly installed under either the C:\WINDOWS\system32 or the C:\WINDOWS\SysWOW64 path on the Windows system.

Diagnosing The Problem

When running "dsmcutil list", the following error is reported:

The program can't start because MSVCR100.dll is missing from your computer. Try reinstalling the program to fix the problem.

Resolving The Problem

  1. From the FlashCopy Manager installation image, locate the msvcr100.dll file. For example, the path looks like the following example: \fcm\x64\vss\<version>\enu\Win\System64
  2. Save or backup the existing msvcr100.dll file from both C:\WINDOWS\system32 and C:\WINDOWS\SysWOW64.
  3. Copy and paste the msvcr100.dll file from the FlashCopy Manager installation image to C:\WINDOWS\system32 and C:\WINDOWS\SysWOW64.
  4. Enter the "dsmcutil list" command. If this command is successful, try the configuration wizard. If the command fails, contact IBM Support.

[{"Product":{"code":"SS36V9","label":"Tivoli Storage FlashCopy Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.1;3.2;4.1","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM FCM

Document Information

Modified date:
17 June 2018

UID

swg21686869