IBM Support

Fixing message Process exited with return code 142 in the message log

Troubleshooting


Problem

This document describes how to fix the message Process exited with return code 142: /bin/sh /bin/sh -c /home/informix/etc/log_full.sh 2 23 "Logical Log 6130 Complete." "Logical Log 6130 Complete." in the message log

Resolving The Problem


PROBLEM

Encountering the following error message in the message log with Informix Server:

    "Process exited with return code 142: /bin/sh /bin/sh -c /home/informix/etc/log_full.sh 2 23""Logical Log 6130 Complete." "Logical Log 6130 Complete."


CAUSE

The ONCONFIG configuration file parameter ALARMPROGRAM defaults to the script $INFORMIXDIR/etc/log_full.sh. The script calls the onbar utility to back up the logical log as soon as it fills up. If you do not use onbar to back up the logical log files, the script will fail and generate the warning in the message log.


SOLUTION

Change the ONCONFIG parameter ALARMPROGRAM to $INFORMIXDIR/etc/no_log.sh. This script does nothing. It does not attempt to back up logical logs when the logical logs fill up. When called, the script will return 0 (success) and the warning messages will stop.
[{"Product":{"code":"SSGU8G","label":"Informix Servers"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF022","label":"OS X"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"10.0;11.1;11.5;7.3;9.4;11.7","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

More support for:
Informix Servers

Software version:
10.0, 11.1, 11.5, 7.3, 9.4, 11.7

Operating system(s):
AIX, HP-UX, Linux, OS X, Solaris, Windows

Document number:
76977

Modified date:
16 June 2018

UID

swg21173842

Manage My Notification Subscriptions