Troubleshooting
Problem
The PowerSC GUI may report communication failures with clients. This technote shows how to fix them.
Symptom
You may go to check compliance of one of your systems, in the PowerSC GUI and receive this popup error:
An error occurred
Communication errors occurred during execution of requested actions. Verify communication on Endpoint Admin page for additional information
Cause
The pscuiagent may not be running on the endpoint system.
Environment
PowerSC GUI 1.1.5
Diagnosing The Problem
To check the communication with this endpoint system, go to the Configuration Tab, then under that the Endpoint Admin tab.
Check the box next to the system you wish to verify, and click the "Verify" icon.

If you receive another popup error like the one below, then the next steps may help resolve the problem.

Resolving The Problem
Log in to the client endpoint system, and check to see if the "pscuiagent" daemon is running:
$ lssrc -s pscuiagent
Subsystem Group PID Status
pscuiagent inoperative
If not you will need to start it:
$ su
root's Password:
# startsrc -s pscuiagent
0513-059 The pscuiagent Subsystem has been started. Subsystem PID is 10682858.
# lssrc -s pscuiagent
Subsystem Group PID Status
pscuiagent 10682858 active
Before logging out, make sure it's set up in /etc/inittab to start after any reboot:
$ grep agent /etc/inittab
pscuiagent:2:wait:/usr/bin/startsrc -s pscuiagent > /dev/console 2>&1
We can see that this system is set up to start the PowerSC client agent at boot time.
After restarting the agent, it may take a few minutes for the GUI server to recognize it has contact again. Back in the PowerSC GUI, verify the system once again, and it should be visible now with no error:

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Document Information
Modified date:
17 June 2018
UID
isg3T1025608