Troubleshooting
Problem
A backup-archive client runs an incremental backup but some files are excluded by the backup even though a specific include statement is added at the bottom of the include/exclude list.
Cause
Working as designed
Diagnosing The Problem
The backup-archive client queries the Windows registry to obtain the list of files that must be excluded. The complete registry key it queries is :
HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
To view the list of files excluded by the Windows operating system, use the following Windows command:
reg query HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
For example, the command reports the following :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
WER REG_MULTI_SZ %ProgramData%\Microsoft\Windows\WER\* /s
Kernel Dumps REG_MULTI_SZ %systemroot%\Minidump\* /s\0%systemroot%\memory.dmp
...
The preceding example shows that the "%systemroot%\memory.dmp" file is excluded by the Windows operating system.
Those files excluded by the Windows operating system are converted by the backup-archive client into exclude statements that are added at the bottom of the include/exclude statements. Because the exclude statements are added at the end of the list, the files are excluded from backup no matter what specific include statement is added to the dsm.opt. file.
Use the backup-archive client command, dsmc q inclexcl, to view the list of include/exclude statements in effect for the client. For example :
dsmc q inclexcl
*** FILE INCLUDE/EXCLUDE ***
Mode Function Pattern (match from top down) Source File
---- --------- ------------------------------ -----------------
Excl Directory *\...\.TsmCacheDir TSM
Excl Directory c:\windows\system32\microsoft\protect Operating System
...
Exclude All C:\windows\Minidump\...\* Operating System
Exclude All C:\windows\memory.dmp Operating System
...
Resolving The Problem
Files that are excluded by Windows cannot be backed up by the backup-archive client. Consult Microsoft support or the vendor of the file to be backed up about instructions for removing the file exclusion from the Windows FilesNotToBackup registry.
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Document Information
More support for:
Tivoli Storage Manager
Software version:
All Supported Versions
Operating system(s):
Windows
Document number:
274309
Modified date:
17 June 2018
UID
swg21972749