Troubleshooting
Problem
The error above may be logged in the SystemOut.log of the IBM WebSphere instance hosting the Content Engine server.
Symptom
[Time stamp] 000030bf ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "executeChanges" on bean BeanId(FileNetEngine#Engine-ejb-ws.jar#Engine, null)". Exception data: com.filenet.api.exception.EngineRuntimeException: DB_ERROR: An error occurred accessing the database. ErrorCode: 0, Message: 'enlist: caught Exception'
...
Caused by: com.ibm.websphere.ce.cm.StaleConnectionException...Caused by: oracle.jdbc.xa.OracleXAException
...
Caused by: oracle.jdbc.xa.OracleXAException
The error above was preceded and appeared to be caused by the following error:
[Time stamp] 000030bf WSRdbXaResour E DSRA0304E: XAException occurred. XAException contents and details are:
The XA Error is : -7
The XA Error message is : Resource manager is unavailable.
The Oracle Error code is : 17002
The Oracle Error message is: Internal XA Error
The cause is : null.
[Time stamp] 000030bf WSRdbXaResour E DSRA0302E: XAException occurred. Error code is: XAER_RMFAIL (-7). Exception is: <null>
[Time stamp] 000030bf ConnectionEve A J2CA0056I: The Connection Manager received a fatal connection error from the Resource Adapter for resource <data source name>. The exception which was received is oracle.jdbc.xa.OracleXAException
Cause
The XA error above indicates a problem related to the connection pool of one of the data sources configured in IBM WebSphere that allows the CE server to access an Oracle database.
Resolving The Problem
Please refer to the link below to an IBM Websphere troubleshooting technote that relates to this topic. In the technote linked below, scroll down to the section "Troubleshooting stale connection problems". There you will find detailed information about troubleshooting and resolving this type of issue, specifically implement the Pretest connection configuration change.
If these types of error persist, please refer to the technote link below for further troubleshooting information or contact WebSphere support for assistance.
Related Information
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Document Information
More support for:
FileNet P8 Platform
Software version:
4.5, 4.0
Operating system(s):
Windows, AIX, HP-UX, Linux, Solaris
Document number:
401127
Modified date:
17 June 2018
UID
swg21422177