Question & Answer
Question
How do I use CE Tracing to troubleshoot FileNet P8 Content Engine issues?
Cause
CE Component Trace Logging provides detailed information on server and client activity by tracing system calls to the following CE components:
- AuthnProvider
- Catalog
- CatClient
- CatService
- ContentCacheService
- ContentRM
- ContentSearch
- DBUtils
- DMAOLEDB
- eContent
- eContentTrans
- ErrorServices
- FCSProvider
- GCD
- GCDProvider
- GCDWizard
- GDSSystem
- INSTALLER
- IsCfsService *
- Manager
- PerfProv
- SecuritySystem
- System
- WebDAV *
- XML Classifier
* Components appear in the list depending on which CE options are installed. For example, the components marked with * above will appear only if their options (CFS and/or Web DAV) are installed
During the initial phase of problem isolation, Engineering might request that several component tracing options be enabled. If the problem can be isolated to a specific area, then the tracing of unrelated components can be disabled.
It is advised to keep all Trace Logging disabled unless you are troubleshooting a specific issue, and/or as directed by IBM FileNet Support personnel, as it can cause a performance impact on the CE processing.
By default, the logs are written to the C:\Windows\temp directory. The logging destination can be changed for each individual component by right clicking on the component icon, selecting “Properties”, and then indicating the new “Log Location”.
Modifications to the trace log output directory are updated in the Registry setting for each component (HKEY_LOCAL_MACHINE\software\filenet\ecm\content engine\tracing\<component_name>). If the output cannot be found in the specified location, verify that the user who is setting this option has proper permission to update the Registry.
Answer
On the CE, start the FileNet Enterprise Manager (FEM). The components for which trace logging can be enabled are located in the tree under
Servers => ServerName => Trace Logging
Each component represents a trace logging service or an area of functionality within a service.
Components can be enabled/disabled individually by right-clicking on the component to bring up its context menu. Alternatively, to enable all components, right-click on Trace Logging and then select “Enable all Components” from the context menu. When it is enabled, a component will have a bright green circle in its icon.
To start the logging, the Content Engine Object Store Service and/or File Store Service must be restarted.
Allow the tracing to run until the target problem occurs.
Data to collect: All logs generated by the tracing options. Include a description of any known circumstances leading up to the issue along with any server error logs. Also document the time at which the issue occurred.
For more information: The “Help on FileNet Enterprise Manager Administration Tool” contains a more detailed write-up on the Trace Logging feature. To access this on-line help select the “Help” option in the FileNet Enterprise Manager, and look under Content Engine Administration -> Trace logging.
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Document Information
Modified date:
17 June 2018
UID
swg21394307