IBM Support

FileNet P8 Content Engine (CE) Apache Debug Logging

Question & Answer


Question

How do I use Apache Debug Logging to troubleshoot FileNet P8 Content Engine issues?

Cause

The Apache HTTP Server, by default, logs diagnostic information and errors that it encounters while processing requests. This error log, typically named error.log, is a key place to look when a problem occurs during server start up or server operation as the log will often include details regarding the failure. Additionally, the Apache server access log records all requests processed by the server.

Answer

The httpd.conf LogLevelparameter adjusts the verbosity of the messages recorded in the logs.

The httpd.conf file is located in the Program Files\Apache Group\Apache2\conf directory. The default level, “warn”, logs warning messages. When troubleshooting an issue, set the LogLevel to “debug”, which will log all levels of messages.

# LogLevel: Control the number of messages logged to the error.log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel debug

Data to collect: The error log and access log files, by default located in the ..\Program Files\Apache Group\logs directory, and the httpd.conf file. Include a description of any known circumstances leading up to the issue along with any server error logs. Also document the time at which the issue occurred.

For more information: See the Apache website.

[{"Product":{"code":"SSNW2F","label":"FileNet P8 Platform"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.5.2;3.5.1;3.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21394303