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Fatal Error: Starting SSL Failed: Certificate Unknown;Error_code=2 (SCI34494)

Troubleshooting


Problem

Fatal Error: Starting SSL Failed: Certificate Unknown;Error_code=2 (SCI34494)

Symptom

Error: Fatal Error: Starting SSL failed: certificate unknown;error_code=2

Cause

Reasons:



1) The trusted.txt file on the client side does not have the correct trusted root certificate that matches the digital certificate being received from the server.     



2) This can be caused by a expired certificate on the keycert.



3) The common name in the certificate from the server is not the fully qualified name so the lookup fails from the client.

Resolving The Problem

Resolutions:



1) Contact the server side and get the correct trusted root certificate and add it to the trusted.txt file.



2) If it's the common name issue you can resolve it by updating the system hosts file and add the common name with the servers IP address but the server side really needs to change  their certificate with the fully qualified host name as the common name.

[{"Product":{"code":"SSFVK3","label":"IBM Sterling Connect:Enterprise for UNIX"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

PRI3058

Product Synonym

[<p><b>]Fact[</b><p>];CONNECT:Enterprise Command Line Client;Release 1.1.01 [<br/>] SCI34494

Document Information

Modified date:
17 December 2019

UID

swg21524535