Troubleshooting
Problem
During the installation of the FastBack Client, the install may fail about half way with error 1722.
Symptom
During the registration of FastBack VSS provider (XR_VSS), installation prompts with the following message:
Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
Cause
The problem is with the COM+ component which is related to the VSS (Microsoft Volume copy Service). The error occurs during the step to register the FastBack VSS provider. After the install process, the XR_VSS service does not get installed or is installed but not registered properly. You can verify that by looking at the services for XR_VSS. During installation or upgrade, FastBack will attempt to register XR_VSS (the FastBack VSS provider). The error is prompted if XR_VSS is already registered.
Resolving The Problem
Follow the steps below to resolve the issue. Move to the next step only if the problem persist
Note: Fastback client directory is:
On 32 bit systems - C:\programfiles\Tivoli\TSM\FastBack\Client
On 64 bit systems - C:\programfiles(x86)\Tivoli\TSM\FastBack\Client
1. Try to manually register the XR_VSS service if it is not listed in Services window:
a. Open a DOS command prompt:
b. Navigate to the FastBack Client directory
c. Run the following command:
On Windows 2003 and 2008 :
cscript.exe register_app.vbs -register XR_VSS FastBackVSS.dll FastBackVSS
On Windows 2008 64bit
FBVSSComServer.exe -regserver cscript register_app.vbs -register XR_VSS FastBackVSS64.dll FastBackVSS
2. Try to manually uninstall and reinstall the XR_VSS service:
Uninstall:
a. Open a DOS command prompt:
b. Navigate to the FastBack Client directory
c. Run the following commands:
FBVssComServer.exe /unregserver cscript register_app.vbs -unregister XR_VSS
d. If the XR_VSS Still shows up in the services open a DOS command prompt and run:
sc XR_VSS -delete
Reinstall:
a. Open a DOS command prompt:
b. Navigate to the FastBack Client directory
c. Run the following command:
On Windows 2003 and 2008 :
cscript.exe register_app.vbs -register XR_VSS FastBackVSS.dll FastBackVSS
On Windows 2008 64bit
FBVSSComServer.exe -regserver cscript register_app.vbs -register XR_VSS FastBackVSS64.dll FastBackVSS
| Note: Both steps might fail with the following error: Error code: -2146368420 [0x8011045c] exit code 112 No messages on com+ errors. If the first two steps fail 3. Reinstall the client using the process below (reboot is required) a. Uninstall FastBack Client b. Reboot c. Go to Control Panel->Administrative Tools->Component Services d. Look under Console Root->Component Serivce->Computers->My Computer->COM+ Application e. Select XR_VSS and choose to delete it f. Reinstall the FastBack Client g. Reboot |
Product Synonym
TSM
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Document Information
Modified date:
17 June 2018
UID
swg21661134