Troubleshooting
Problem
Why is the installation of the 64-bit NetBackup 6.5.x client failing?
Symptom
When attempting to install the Symantec NetBackup 6.5.x client on a 64-bit RedHat system, the installation fails with the error message 'libacl.so.1: cannot open shared object file'.
Cause
Even with the 64-bit NetBackup client installations, Symantec ships a 32-bit binary 'tar' that is used to unpack the installation files. This version of tar is customized and it requires that the 32-bit version of all of the libraries that it references must exist.
Netezza began shipping systems running the 64-bit version of RHEL5.2 in late 2008. These systems do not have the 32-bit version of the libacl package installed. Netezza is aware that installations of the 64-bit NetBackup client will fail (with the error noted above) until Symantec ships a 64-bit tar command with its installation package.
Resolving The Problem
1. To resolve this issue, you must first identify which build of the libacl package is installed (64-bit version). This can be done by running the following command:
rpm -qa libacl
This will return something similar to:
libacl-2.2.39-3.el5
2. You must then find a source (http://rpm.pbone.net) and download the 32-bit build of the same version of this package.
3. After you have installed the 32-bit libacl package, confirm that both packages are installed by running the command again:
rpm -qa libacl
The command output should be similar to the following:
libacl-2.2.39-3.el5
libacl-2.2.39-3.el5
4. Install the NetBackup client.
The following is a link to the Symantec forum summarizing this issue:
http://seer.entsupport.symantec.com/docs/303001.htm
Historical Number
NZ848396
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Document Information
More support for:
IBM PureData System
Software version:
1.0.0
Document number:
461957
Modified date:
17 October 2019
UID
swg21569647