Troubleshooting
Problem
Attempting to open the iBase database on the server gave an error “Invalid Encryption Data” or "Failed to encrypt data". This may occur in IBM i2 iBase and the iBase scheduler.
Cause
This was traced to a problem with the (Microsoft Windows operating system defined) encryption policies on the iBase server.
Resolving The Problem
This was fixed by altering the following registry key to zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy
If you cannot disable FIPSAlgorithmPolicy (FIPSAlgorithmPolicy=0 in the registry), then set enforceFIPSPolicy to false in the iBase.exe.config file. This does not weaken the security of iBase.
C:\Program Files (x86)\i2 iBase 8\iBase.exe.config
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<startup>
<supportedRuntime version="v4.0" />
</startup>
<runtime>
<generatePublisherEvidence enabled="false"/>
<enforceFIPSPolicy enabled="false" />
</runtime>
</configuration>
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Document Information
Modified date:
15 October 2018
UID
swg21982386