Troubleshooting
Problem
Attempts to run a performance test against an SSL application result in error " ... Host is unreachable. ...".
Symptom
The full error message is as follows:
.
Failed to connect to "ipaddress:portnumber" after 101 attempts:[24.7.5.6] Host ipaddress:portnumber
is unreachable
No request sent
IBM Rational TestManager stops responding and sends this error to the log.
Cause
This error has multiple causes. Technote 1161537 addresses one cause.
The SSL RSA key size is another possible cause. Rational TestManager does not support a key size above 2048 bytes.
Diagnosing The Problem
To verify the key size, do the following steps.
- Start Internet Explorer and connect to the site that you want to test.
- Navigate to the point where the browser loads the first SSL page. You can see from the padlock icon at the bottom of the window.
- Open the Certificate window.
In older Internet Explorer versions, you double click on the padlock icon.
In newer versions you click Certificate error > View certificates.
- Go to the Details tab of the Certificate window.
- Scroll down to the Public Key Field. Then look at the value. If you see an RSA value higher than 2048, TestManager is unlikely to playback properly.

Resolving The Problem
Use IBM Rational Performance Tester 7.0.2 or newer. These versions are designed to successfully handle certificates with 4096-bit public keys.
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Document Information
Modified date:
16 June 2018
UID
swg21208254