Troubleshooting
Problem
When connected to an IBM i2 iBase Database (DB), the command "Extract Chart Items" does not work. Clicking on this command does nothing. No window is displayed.
Symptom
In IBM i2 Analyst's Notebook, when connected to an IBM i2 iBase database, the Data toolbar on the right displays some commands.
One of them is "Extract Chart Items..." :

Clicking on this command should display a window after 2 to 5 seconds after clicking :

If no window is displayed after this time, then the solution described below applies and will explain how to fix the problem.
Cause
The reason is that the function "Chart Items Extractor" of iBase has not been installed on iBase.
Please note that the installation of this function is in iBase, not in Analyst's Notebook.
Diagnosing The Problem
Check in the iBase installation that the function "Chart Items Extractor" has been installed.
Resolving The Problem
1) Close IBM i2 Analyst's Notebook and IBM i2 iBase.
2) Go to the Start menu of Windows, then Control Panel.
3) Select Add or Remove Programs (or Programs and Features, depending on your Windows).
4) Select iBase, and click on "Modify" (or "Change", depending on the Windows OS)
5) Click on Modify
6) In the list of features, open the "Extended Features", and scroll down to "Chart Items Extractor".

7) Select it to install it.
8) Continue the install to the end.
9) Restart Analyst's Notebook and reconnect to the iBase Database
10) Add some entities to the chart, or open an existing chart
11) Click on the "Extract Chart Items" command to see if the faeature is now working correctly.
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21678054