IBM Support

Extending Eclipse fails with Java VM not found error message

Troubleshooting


Problem

This technote identifies a defect that impacts IBM® Installation Manager package installation into an existing Eclipse™ setup on Microsoft® Windows®.

Symptom

The problem may affect both silent install and User Interface install.

  1. When using silent install to install a package into an existing Eclipse with the following command line options on Windows, the following error is written to the install log:

    C:\Program Files\IBM\Installation Manager\eclipse>IBMIMc.exe --launcher.ini silent-install.ini -input <response file> -log <log file>

    Error in Log:

    VM used by existing Eclipse installation <existing Eclipse location> incompatible with Package's JVM requirements.

  2. When using the UI to install a package into an existing Eclipse right after updating Installation Manager to V1.2, you may find the Installation Manager picks up the wrong JRE and complains that the package can only use a certain version of JRE.

Cause

If the Eclipse.ini in your existing Eclipse does not specify a VM, the Installation Manager will search for a VM in the environment PATH variable. However, on Windows, Installation Manager erroneously ignores the first 2 or 4 entries in the PATH during the silent install, thus fails to find the correct VM used by the existing Eclipse.

Resolving The Problem

A defect has been submitted to address this behavior and will be resolved in the release following 1.2 of Installation Manager.

WORKAROUND:

Launch your existing Eclipse installation and verify that Eclipse is using the correct JRE by looking in the Help > About Eclipse > Configuration Details.

Next, before running the silent install, open Control Panel > System (or right-click on My Computer and choose "Properties"), then click Advanced > Environment Variables.

Add four directories that do not contain any JVM in the beginning of either the user or system environment PATH.

Or, if you use the UI, after the Installation Manager update is finished and re-launched, quit and restart the Installation Manager again to install the package.

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Document Information

More support for:
IBM Installation Manager

Software version:
1.0, 1.0.0.1, 1.0.0.2, 1.0.0.3, 1.0.0.4, 1.0.0.5, 1.1, 1.1.0.1, 1.1.0.2, 1.1.1, 1.1.2, 1.2

Operating system(s):
Windows

Document number:
359359

Modified date:
25 October 2021

UID

swg21319892

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