IBM Support

'An Extended Error Has Occurred' When Mapping a Network Drive

Troubleshooting


Problem

'An Extended Error Has Occurred' When Mapping a Network Drive occurs as a result of invalid credentials being passed on the drive mapping attempt.

Symptom

When attempting to map a NetServer drive, a message is returned saying the mapped drive "cannot be created because of the following error - an extended error has occurred".

Cause

This error can be returned when the client PC is sending an invalid User ID (one that does not exist on the IBM i). For example, if the user logs on a Domain with a profile that is different than the user's IBM i ID (and that does not exist on the IBM i).

The drive can be mapped successfully by one of the following methods:

1) Using the "Connect using different credentials" option from the Windows Map Network Drive GUI, and specifying a valid IBM i User ID.

2) Use a log on script that provides valid IBM i User ID and password.

3) Store valid IBM i User ID and password in Windows Credential Manager. See IBM Technote N1019212 'Connecting a NetServer Drive Automatically When Microsoft Windows XP or Windows 7 Password Is Different Than the IBM System i Password'

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0"}]

Document Information

More support for:
IBM i

Software version:
7.1.0

Operating system(s):
IBM i

Document number:
666481

Modified date:
18 December 2019

UID

nas8N1020932

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