Troubleshooting
Problem
A Citrix or Microsoft Terminal Services administrator noticed that the server disk was nearing full and checked the areas related to 3 types of cache files created by Cognos Controller. These folders seemed to be unusually large. Can the I.T. administrator clear any of these files?
Symptom
Disk on Citrix or Terminal Server (TS) machine is full.
Cause
There are 3 types of cache folder used by Cognos Controller:
(1) Microsoft Internet Explorer cache at C:\Documents and Settings\%USERNAME%\Local Settings\Temporary Internet Files
(2) Microsoft .NET components at C:\Documents and Settings\%username%\Local Settings\Application Data\assembly
(3) Controller user cache files: at C:\Documents and Settings\%appdata%\Application Data\Cognos\ccr\
For more information on the above folders, see separate IBM Technote #1347422.
On a Citrix/TS server, there will be multiple users logging on to use Controller, therefore the effect of the above is multiplied many times.
Diagnosing The Problem
Analyse the disk space usage for the above 3 folders. After doing this, you may find that some of the following questions arise:
- (a) Why are the 'Assembly' cache folders on his system orders of magnitude larger than expected and why are there duplicate files under different sub-folders?
- (b) For all 3 cache types, what can be safely deleted and what if anything would the effect on users be?
Resolving The Problem
Typically there is no benefit to clearing all the files that are mentioned above, because most of them will simply be re-downloaded the next time the end user launches Controller. In other words, there has not been any long-term disk benefit, but there will be a performance penalty for the end user the next time they launch Controller (during when the system re-downloads the components/cache).
For a more in-depth explanation, see below:
(a) 'Assembly' cache folders
If the same DLLs (for example ControllerXL.DLL) exist multiple times they may be for different Controller versions.
- Therefore, there can be a benefit to clearing cache before performing a Controller version upgrade
- In other words, it is useful to clear down the Assembly folder when upgrading Controller versions.
(b) what cache be safely deleted?
- Cache Type 1 - Internet Explorer cache
- This can be cleared any time via IE Tools > Internet Options > Delete Files
- From the same place the Settings control can set the maximum IE cache size
- Cache Type 2 - Assembly folder
- So long as the relevant User is logged off, contents of this cache folder can be safely deleted.
- There will be a loss of performance initially as the used DLLs and other components are recreated in this cache.
- Performance will improve as soon as frequently used files are present in this cache
- Cache Type 3 - User cache
- This cache can be tidied up by User's Controller Client program, via Maintain > Special Utilities > Clear Local Cache.
- For a complete clear down, via Windows File Explorer, delete all files except for ccr.config.
- ccr.config itself may be deleted with the consequence that the User may lose some of their style preferences or file paths as used in their Controller menu workspace.
- Sometimes there is a genuine reason to delete the ccr.config file (for example due to a corruption, see for example Technote 1367043).
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21397747