IBM Support

Exchange Powershell commands to restore an individual mailbox

Question & Answer


Question

Which Exchange Management Shell (powershell) commands would be used to restore a mailbox?

Cause

If the Data Protection Individual Mailbox restore is failing or cannot be completed, it is possible to use the Exchange Powershell commands to restore the mailbox.

Answer

The following steps can be used to restore an individual mailbox:

The environment is as follows:

    Exchange Server name: EXCHMAIL01
    Mailbox name: tsmuser01
    Database with mailbox tsmuser01 in it: MDB013
    Temp Mailbox name: tempuser02

Step#1. Create a recovery DB(for example named TSMRDB-DEBUG.edb on x: drive) and leave it unmounted on Exchanger Server that restore is performed(for example named EXCHMAIL01)

Step#2. Open Data Protection Management Console GUI-> "Protect and Recover Data"-> "Exchange Server - EXCHMAIL01"

Step#3. Click "Recover" tab -> Select "Database Restore" -> Select "All Backups", and search for the database with the mailbox in it (for example MDB013)

Step#4. Highlight the date/time of the backup to be restored.
( NOTE: With "Auto Select" set to true, if an incremental is selected, it will highlight back to the closest compete full backup prior)

Step#5. Right click on highlights, and select on “Restore Into” and choose the recovery database "TSMRDB-DEBUG"

Step#6. Click on “Show Restore Options” and set these restore options:
Auto Select True
FromExcServer *
Instant Restore False
Mount database after restore False
Replay Restored & Current Logs False
Replay Restored logs only True
Run Recovery True




Step#7. Click on Restore, there will be 2 warning windows pop-up as in below, click on "Yes" on both:

cid:image002.png@01CFB58C.3FC49350


after clicking "Yes":

cid:image003.png@01CFB58C.80E872C0



Step#8: After the full backup is restored and the logs are replayed, the health of restored database can be checked using the Exchange Management Shell command:

[PS] C:\>eseutil /mh x:\RDB\TSMRDB-DEBUG.edb

Step#9: If the database is in a clean shutdown state, have the database mounted

Step#10: Create a Mailbox Export Request by using the powershell command line to export the mailbox to a temp mailbox

[PS] C:\>Restore-Mailbox -Identity tempuser02 -RecoveryDatabase TSMRDB-DEBUG -RecoveryMailbox tsmuser01 -TargetFolder Recovery

Step#11: Export Mailbox to .pst into a shared folder URL.
11a) Create a folder on the x:\ and share it with everyone read\write.
11b) Export the mailbox to a .pst file
[PS] C:\>New-MailboxExportRequest -Mailbox tempuser02 -FilePath \\EXCHMAIL01\TSM User\tsmuser01_restore.pst

11c)Check whether Exchange Request is queued or in progress
[PS] C:\>Get-MailboxExportRequest -Mailbox tempuser02

11d) Check the progress, i.e., % completed of exporting the mailbox to the.pst file
[PS] C:\>Get-MailboxExportRequest -Mailbox tempuser02 | Get-MailboxExportRequestStatistics

Step#12: After export request is completed, use outlook to valid the restored .pst file, i.e, tsmuser01_restore.pst
[{"Product":{"code":"SSTG2D","label":"Tivoli Storage Manager for Mail"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for MS Exchange","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.1;6.1.1;6.1.2;6.1.3;6.3;6.3.1;6.4;6.4.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

More support for:
Tivoli Storage Manager for Mail

Software version:
6.1, 6.1.1, 6.1.2, 6.1.3, 6.3, 6.3.1, 6.4, 6.4.1

Operating system(s):
Windows

Document number:
243553

Modified date:
17 June 2018

UID

swg21668964