Troubleshooting
Problem
Application stops functioning due to lack of disk space. The logs\XQE folder structure fills with planning and execution folders that consume large amounts of disk space. Requiring disk clean up and application restart.
Symptom
Disk space is consumed rapidly and causes the application to fault.
Cause
Additional tracing enabled
Environment
All platforms
Diagnosing The Problem
Review the logging enabled and ensure all tracing has been turned off or disabled.
More specifically the dispatcher logging for:
Enable query execution trace
Enable query planning trace
Resolving The Problem
To resolve the disk consumption, disable the following traces in Cognos Administration:
Enable query execution trace
Enable query planning trace
Steps:
- Login to the Cognos Portal and go into the Cognos Administration page.
- Under the Status tab - System selection, click into your reporting server(s) and then open the properties of dispatcher.
- Ensure the following two traces are not checked:
Enable query execution trace
Enable query planning trace
If checked, uncheck them, click OK, and restart the dispatcher for the changes to take effect
Note: These traces are typically used for debugging. They should only be enable to troubleshoot the XQE engine's processing. They will hamper processing if enabled.
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Document Information
Modified date:
15 June 2018
UID
swg22006944