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Exception thrown by servlet cmisatom11: java.lang.NoClassDefFoundError:org.apache.commons.lang3.StringEscapeUtils in Content Management Interoperability Services (CMIS)

Troubleshooting


Problem

In Content Management Interoperability Services (CMIS) 1.1, an exception appears in the WebSphere Application Server (WAS) SystemOut.log file when creating a folder in teamspace and importing new documents into this folder.

Symptom

[3/16/17 15:15:54:958 CET] 00000109 ServletWrappe E com.ibm.ws.webcontainer.servlet.ServletWrapper service Uncaught service() exception thrown by servlet cmisatom11: java.lang.NoClassDefFoundError: org.apache.commons.lang3.StringEscapeUtils
        at org.apache.chemistry.opencmis.server.impl.atompub.CmisAtomPubServlet.printError(CmisAtomPubServlet.java:366)
        at org.apache.chemistry.opencmis.server.impl.atompub.CmisAtomPubServlet.service(CmisAtomPubServlet.java:213)

        .

        .
       at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1881)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang3.StringEscapeUtils
       at java.net.URLClassLoader.findClass(URLClassLoader.java:432)
       .

        .
       at com.ibm.ws.classloader.CompoundClassLoader.loadClass(CompoundClassLoader.java:617)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:663)
       ... 28 more

Cause

WAS is unable to identify which jar files it should load as there are duplicate jars. This causes the NoClassDefFoundError to appear in the application server log.

Environment

FileNet Content Engine 5.2.1

ICN 2.0.3 Fix Pack 8

CMIS 1.1

Diagnosing The Problem

Navigate to the installedApp directory, similar to C:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\P8Node01Cell\navigator.ear\openfncmis.war\WEB-INF\lib

Check if the following files are duplicated in that directory:

commons-logging-1.1.1.jar
jaxb-core-2.2.10-b140802.1033.jar
jaxb-impl-2.2.10-b140802.1033.jar
stax2-api-3.1.1.jar
woodstox-core-asl-4.2.0.jar

Resolving The Problem

1. Identify any duplicate files.

2. Keep the latest version of jar files.

3. Back up the older jar versions and remove them.

4. Redeploy the ICN application using the IBM Content Navigator Configuration and Deployment tool or via the WAS console.

If the issue still remains after performing the steps above, replace the backed up jar files to their original directory. Download the jar file from this link and add the commons-lang3.jar file to the openfncmis.war/WEB-INF/lib directory.

Redeploy the application.

Related Information

[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"CMIS for FileNet Content Manager","Platform":[{"code":"PF016","label":"Linux"}],"Version":"2.0.3.8","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]

Document Information

Modified date:
17 June 2018

UID

swg22001193