IBM Support

Exception from HRESULT: 0x80010001 (RPC_E_CALL_REJECTED)

Troubleshooting


Problem

Unable to load a report in FSR. FSR closes with the below error.

Symptom

Type: COMException

Message: Call was rejected by callee. (Exception from HRESULT: 0x80010001 (RPC_E_CALL_REJECTED))

Stack Trace: at Excel.ApplicationClass.st_EnableEvens(Boolean RHS) at Clarity.FSR.UI.Controls.ExcelControl.InitializeExcel()

at Clarity.FSR.UI.FormsLayoutForm.LayoutForm_Load(Object sender, EventArgs e)

at System.EvenHandler.Invoke(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at System.Windows.Forms.Form.OnCreateControl()

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible) ...

Cause

Excel is not able to initialize from within FSR. Other addins can cause this.

Diagnosing The Problem

Notice that the details of the error above relate to Excel, not Word as other very similar errors.

Resolving The Problem

- Disable all addins in Excel

- Access FSR

If this is now working, add each of the addins back and find out which one causes the issue.

It may be that the version is not supported with FSR, or that these two (FSR and Excel addin in question) cannot be used on the same workstation.

[{"Product":{"code":"SSJSTG","label":"Cognos Financial Statement Reporting"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.6","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21594848