IBM Support

Error: Word Automation server could not be started, when opening a RequisitePro document

Troubleshooting


Problem

This technote outlines steps to resolve the following Microsoft® Word automation error when a user tries to open a document in IBM® Rational® RequisitePro®.

Cause

The error message that appears is as follows:


The Word automation server could not be started.

This error can also appear with the following:

Reason: Access is denied ( HRESULT E_ACCESSDENIED)

This specific Reason is displayed when general DCOM security settings on the machine are blocking the current logged in user. This specific user does not have the Default Access Permission to start the COM server that requires an external process (so called out of process server). While most COM objects do not use this kind of COM server (they are hosted by a DLL), WinWord and Excel are using an external process.

Resolving The Problem

The DCOM configuration needs to be changed on this machine to allow RequisitePro to launch Word.

Configure the DCOM entry for Word on the machine by following these steps:

  1. Select the Run... command from the Start menu. Type in dcomcnfg (Do not type the quotes)
  2. Select the Microsoft Word Document entry in the Applications tab
  3. Select Properties
  4. Go to the Security tab
  5. Check the Use custom access permissions radio button and click on Edit. Then add the Interactive User from the local machine.
  6. Check the Use custom launch permissions radio button and click on Edit. Add the
    Interactive User from the local machine.
  7. Then go to the Identity tab
  8. Select the Interactive User
  9. Click on OK twice to exit the DCOM configuration.
  10. Reboot the PC before opening RequisitePro again.

Log in as a user with local Administrative rights.

Modify the DCOM Settings, assign Access Permissions to the INTERACTIVE user.

  1. On the Start Menu, click Run, and type dcomcnfg
    Note: At this point you may see the DCOM Configuration Warning dialog box. Accept the warning and proceed to the next step.
  2. Select the Default Security tab. Under Default Access Permissions, click the Edit Default option.
  3. In the Registry Value Permissions dialog box, click Add.
  4. In the Add Users and Groups window, select the local machine from the List Names list box.
  5. In the Add Users and Groups dialog box, click Show Users.
  6. Select the INTERACTIVE user from the list and click Add.
  7. At the Type of Access field, select Allow Access.
  8. Click OK twice to return to the DCOM Configuration dialog.
  9. Close DCOM and restart your system.


The other option is to reset the Default Access Permission to installation default, which is an empty list.



[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Word Integration: Document open\/close\/save","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2002.05.20;2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

162569804

Document Information

Modified date:
16 June 2018

UID

swg21142726