IBM Support

Error while Building Custom Modules in Call Center

Troubleshooting


Problem

While creating a custom module/application in the Call Center, the following steps were successfully completed:
 
- Creating custom modules.
- Registering routes or modules.
 
However, the issue occurred when attempting to build the custom modules or routes as per the instructions provided in the link below:
https://www.ibm.com/docs/en/call-center/10.0?topic=applications-building-custom-modules-routes
 
After following the steps in the documentation, the following error was encountered:
 
Command Executed: ./build-customization.sh build-ui call-center-password
Building UI module: call-center-password
Running yarn install
yarn install v1.22.19
[1/4] Resolving packages...
[2/4] Fetching packages...
error "..\\lib/buc/common-components/common-components-4.18.3.tgz":
Tarball is not in network and can not be located in cache
(["/var/lib/jenkins/workspace/testing-Release-to-OMoC-Call-Center/callcenter-code/call-center-password/..\\lib/buc/common-components/common-components-4.18.3.tgz",
"/home/builder/.cache/yarn/v6/npm-@buc-common-components-4.18.3-0915485dcb5b424fcbe7b4fcf8722ef2b6c9e54b/node_modules/@buc/common-components/.yarn-tarball.tgz"])
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
An error occurred running yarn install.

Cause

The issue appeared because the required tarball for the "common-components-4.18.3.tgz" could not be found in the network or in the cache. This occurred because the tarball was missing from the specified paths or improperly cache in the local environment.

Environment

The issue occurred in a local DTK environment while building the "call-center-password" module.

Diagnosing The Problem

An attempt was made to resolve the issue by increasing the network timeout, using the following command:
 
yarn install --update-checksums --network-timeout=30000
 
However, this did not resolve the problem. After further diagnosis, it was determined that the issue lies with the "common-components-4.18.3.tgz" file being unavailable or incorrectly referenced.

Resolving The Problem

To resolve the issue, the following steps were followed:
 
1. Clean Yarn Cache:
    Run the command from the root directory to clean the Yarn cache ($HOME_DIR/call-center-code/):   
    yarn cache clean
2. Remove the "node_modules" and "yarn.lock" files from both the root directory and the newly created module:  
     rm -rf node_modules yarn.lock 
   
    Execute this command in:
     - Root directory ($HOME_DIR/call-center-code/)
     - Newly created module ($HOME_DIR/call-center-code/call-center-password)
 
3. Reinstall Packages with Updated Checksums increasing network timeout:
    yarn install --update-checksums --network-timeout=30000
    Execute this command in Root directory and Newly created module.
 
4. Add the following resolution to both the root and the "call-center-password" module's "package.json" to force Yarn to use a specific version of the "common-components" tarball:
   "resolutions": {
   "@buc/common-components": "file:../lib/buc/common-components/common-components-4.18.3.tgz"
   }
5 . Clean Specific Cache for @buc/common-components:
    yarn cache clean @buc/common-components
 
Following these steps resolved the build issue, and the custom module "call-center-password" was successfully built.

Document Location

Worldwide

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Document Information

Modified date:
21 February 2025

UID

ibm17171498