IBM Support

Error when installing Rational TestManager v7.0.2: Error expanding installation packages

Troubleshooting


Problem

This technote describes root cause of “expanding installation packages In root installation context: No included version of component” error when upgrading IBM RationalTestManager 7.0.2 version and other IBM Rational products with 7.1.0.2 versions.

Symptom

Install configurations are 7.1.0.2 fix pack version of IBM Rational ClearCase, IBM Rational ClearQuest and IBM Rational RequisitePro, IBM TestManager version 7.0.2 and IBM Installation Manager v1.3.3.

Attempting to upgrade all install products once by means of IBM Installation Manager results in this error:


    <message>Error expanding installation packages
    In root installation context:
    No included version of component
    "com.ibm.team.java.common.installcontext" meets all tolerances
    Version 20.0.0.20091202_1347 does not satisfy require tolerance
    [1.0.0,20.0.0) in component "com.ibm.rational.testmanagermain"
    Version 20.0.0.20091201_1104 does not satisfy require tolerance
    [1.0.0,20.0.0) in component "com.ibm.rational.testmanagermain"
    Version 7.1.2.0000-7-1-0-02-00-2009B-D090612 does not satisfy
    require tolerance [20.0.0,21.0.0) in component
    "com.ibm.rational.clearcase.assembly"
    No included version of component "microsoft.vc80" meets all
    tolerances
    Version 7.1.1000.0000-7-1-1-D091027 does not satisfy include
    tolerance [1.0.0,7.1.3) in component "com.ibm.rational.testmanagermain"
    In installation context "com.ibm.sdp.native":
    No included version of component "ibm.icu4c" meets all tolerances
    Version 7.1.1000.0000-7-1-1-D091027 does not satisfy include
    tolerance [1.0.0,7.1.3) in component "com.ibm.rational.testmanagermain"
    Version 1.0.0.00-7-1-D081104 does not satisfy include tolerance
    [7.0.0,8.0.0) in component "com.ibm.rational.clearcase.assembly"
    No included version of component "macrovision.flexnet" meets all
    Tolerances…….”

Resolving The Problem

The error is cause by the incompatibility problem between TestManager v7.0.2 and the ClearCase and ClearQuest v7.1.1 newest upgrade product versions.

The last supported version of ClearCase and ClearQuest with TestManager is version 7.1.0.2.

As a workaround, you can keep TestManager v7.0.2 version on the separate test machine.

[{"Product":{"code":"SSSHVH","label":"Rational TestManager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.2","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21417606