IBM Support

Error updating IBM Installation Manager

Troubleshooting


Problem

Attempts to update IBM Installation Manager results in the error "Error updating" that shows a list of missing files.

Symptom

The following (or similar) error messages are displayed when updating IBM Installation Manager.

Depending on which version of IBM Installation Manager you are updating to the missing files names will be different as they directly correspond to the version of IBM Installation Manager you are upgrading to.

The below example is what you would see if you were upgrading to IBM Installation Manager 1.3.1


Error updating.
'zip jre.win32.x86 5.0.3.sr8a_20080811b' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\native\jre.win32.x86_5.0.3.sr8a_20080811b.zip).

'plug-in com.ibm.cic.agent.core.nativeInstallAdapter.win32_1.2.5.v20090515_0601' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.cic.agent.core.nativeInstallAdapter.win32_1.2.5.v20090515_0601.jar).

'plug-in com.ibm.cic.common.core.win32_1.0.6.v200901201635' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.cic.common.core.win32_1.0.6.v200901201635.jar).

'plug-in com.ibm.cic.licensing.flexlm_7.0.201.v20090605_0600' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.cic.licensing.flexlm_7.0.201.v20090605_0600.jar).

'plug-in com.ibm.cic.licensing.lum_7.0.22.v20090605_0600' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.cic.licensing.lum_7.0.22.v20090605_0600.jar).

'plug-in com.ibm.cic.licensing.lum.win32_7.0.4.v20081120' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.cic.licensing.lum.win32_7.0.4.v20081120.jar).

'plug-in com.ibm.ws.pak.internal_1.0.0.v20090528_0601' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\com.ibm.ws.pak.internal_1.0.0.v20090528_0601.jar).

'plug-in org.apache.ant_1.7.0.v200803061910' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.apache.ant_1.7.0.v200803061910.jar).

'plug-in org.eclipse.core.runtime.compatibility.registry_3.2.200.v20080610' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.eclipse.core.runtime.compatibility.registry_3.2.200.v20080610.jar).

'plug-in org.eclipse.equinox.launcher.win32.win32.x86_1.0.101.R34x_v20080731' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.0.101.R34x_v20080731.jar).

'plug-in org.eclipse.equinox.launcher.win32.win32.x86.nl1_1.0.101.v200809240100' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.eclipse.equinox.launcher.win32.win32.x86.nl1_1.0.101.v200809240100.jar).

'plug-in org.eclipse.equinox.launcher.win32.win32.x86.nl2_1.0.101.v200809240100' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.eclipse.equinox.launcher.win32.win32.x86.nl2_1.0.101.v200809240100.jar).

'plug-in org.eclipse.equinox.launcher.win32.win32.x86.nl2a_1.0.101.v200809240100' does not exist in C:\temp\agent.installer.win32.win32.x86 (at C:\temp\agent.installer.win32.win32.x86\plugins\org.eclipse.equinox.launcher.win32.win32.x86.nl2a_1.0.101.v200809240100.jar).

Cause

This is caused by not using the package com.ibm.cic.agent.offering.zip.

Resolving The Problem

When setting up a repository for an update you must use the com.ibm.cic.agent.offering.zip download package.

WORKAROUND:

If you already have the platform specific zip file downloaded, you can update IBM Installation Manager using that version by clicking on install.exe (to update using the GUI) or run this from the command line to update silently:


installc.exe --launcher.ini silent-install.ini




Note: This workaround will work for upgrading on a local machine. For enterprise deployment use the first solution with package com.ibm.cic.agent.offering.zip.
[{"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Update","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.3;1.3.1;1.3.2;1.3.3;1.3.4;1.3.4.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
IBM Installation Manager

Software version:
1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.4.1

Operating system(s):
Windows

Document number:
391997

Modified date:
25 October 2021

UID

swg21393003

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