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Error: Unable to set up the current user's profile

Troubleshooting


Problem

During the install of Lotus Forms Viewer onto a system with Microsoft Windows Vista, an error message occurs stating that the program was unable to set up the current user's profile.

Cause

After migrating the user's information from Windows XP to Windows Vista. The registry was modified to point to the old Windows XP path. For example, the Common AppData registry was modified to the Windows XP path (C:\Documents and Settings\All Users\Application Data), which caused the error.

Resolving The Problem

The Forms Viewer requires read/write access to at least four locations. The directory locations are determined by querying the following registry keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\AppData

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Personal

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Desktop

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common AppData

If you examine a new Windows Vista Business install, these registries point to the following locations:


    AppData -> C:\Users\<user name>\AppData\Roaming

    Personal -> C:\Users\<user name>\Documents

    Desktop -> C:\Users\<user name>\Desktop

    Common AppData -> C:\ProgramData


One troubleshooting step is to confirm that these four registry keys are pointing to the correct Windows Vista locations.

Related Information

[{"Product":{"code":"SS38QR","label":"Lotus Forms Viewer"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.0.1;4.0;3.5;3.0.1;3.0","Edition":"","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
16 June 2018

UID

swg21296695