IBM Support

Error returned when using the CLI:  "The ndm_auth() function returned NULL, meaning that the user authentication did not complete properly". (SCI24054)

Troubleshooting


Problem

Error returned when using the CLI:  "The ndm_auth() function returned NULL, meaning that the user authentication did not complete properly". (SCI24054)

Symptom

ERROR: The ndm_auth() function returned NULL, meaning that the user authentication did not complete properly.
XAPI005I
ERROR: The authentication process took too long. This could indicate an attack in process
UNABLE to get into the command line interface
XSEC010I

Cause

TCQ is not able to handle a queue greater than (aproximately) 80 processes

Resolving The Problem

New fix available for Connect:Direct Unix 3.5.00. Apply maintenance for CONNECT:Direct that was created on or after December 2002.

[{"Product":{"code":"SSFVK3","label":"IBM Sterling Connect:Enterprise for UNIX"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

PRI715

Product Synonym

[<p><b>]Fact[</b><p>];CONNECT:Direct UNIX, all versions. [<br/>] SCI24054

Document Information

Modified date:
17 December 2019

UID

swg21521688