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Error "Requested registry access is not allowed," when a non admin user launch VMware VI Client or vSphere Client

Troubleshooting


Problem

This problem is non critical and can be ignored, Despite the error "Requested registry access is not allowed" being displayed, A user can click (ok) and proceed to login normally. This error is reported when a non administrator user first attempts to logon to vSphere or VI client. This is also documented on VMware KB 1009284 (http://kb.vmware.com/kb/1009284) and says it effects VirtualCenter version 2.5, however this can happen on different versions.

Symptom


When a non admin user launches VC Client, VI client MAY display a "Requested registry access is not allowed" error message. Clicking "OK" will close the error dialog so the user may proceed.

Cause


Root cause:

vCenter stores settings at registry key

"HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VirtualCenter".

This key and similar product keys are created by the installer during product installation. The key is supposed to inherit the default permissions from parent. The default permissions are FullControl for administrators, owner, system; Read for power users and users. Instead the key has access rights for only the administrators and the system. This is the root cause of the vSphere/VI client bug.

The VI client launcher will display "localhost" as the default address when the client is run on the same computer as the VC server. The client launcher detects if VC is installed by reading

"HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VirtualCenter\InstalledVersion"

registry value.

When a non admin user is trying to launch the client on the same machine as the VC server, the
client launcher will fail to read the named registry key. This will result in an exception in client launcher code.

Environment

VMware VI client or vSphere client

Diagnosing The Problem


Examine the vSphere client log

If vCenter server is runing on a Windows 2008, do enable "show hidden files". Then browse to
C:\Users\test\AppData\Local\Vmware\vpx\

Check for viclient.log for the following messages

System.UnauthorizedAccessException: Access to the registry key
'HKEY_CLASSES_ROTT\VpxClient' is denied.
....
....
Error: Unhandled exception.
System.Security.SecurityException: Requested registry access is not allowed.

Resolving The Problem


1. Log in Windows as "administrator" on the vCenter server
2. Open regedit
3. Go to "HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VirtualCenter"
4. Right click on the Key, then go to 'Permissions'
5. Add read permissions to this key for "Users".


The "HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VirtualCenter" Key may be in the Wow6432Node folder depending on the machine vCenter is installed on. This issue can also occur when an older vCenter version is upgraded, since Key permissions are not altered when upgrading existing Keys. This can also occur in new installations during the Key creation phase if permissions are not added correctly.

The above fix is a permanent resolution and will not cause any other issues as it is setting a permission to the way it is meant to be set.

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Document Information

Modified date:
28 January 2020

UID

isg3T1019364