IBM Support

"Error: 'ReportDispatcherEntry' is undefined" when running Standard Reports

Troubleshooting


Problem

User runs any standard report (also known as 'system reports'). User receives an error. If the user clicks 'Yes' then a new/different error. After clicking 'Yes' to this, a new error appears etc.

Symptom


Script Error
An error has occurred in the script on this page
Line: 32
Char: 1
Error: 'ReportDispatcherEntry' is undefined
Code: 0
URL: http://servername/ibmcognos/rv/serverrequest/requests/standalone/ViewerDispatcherEntry.js
Do you want to continue running scripts on this page?
[Yes] [No]


'ServerRequest' is underfined


Unable to get property 'setSelectionBasedFeaturesEnabled' of undefined or null reference

Unable to get property 'addMetaData' of undefined or null reference

Unable to get property of 'addContextData' or underfined or null reference

Cause

There are several known causes for similar errors.

  • TIP: See separate IBM Technote #2011388 for more potential causes.

This Technote specifically relates to the scenario where the cause is invalid cache files inside client device's Internet Explorer.

Environment

Problem does not affect all client devices.

Example:

In one real-life example:

  • The server had recently been upgraded from Controller 10.1.1 to 10.2.
  • The problem only appeared when running the Controller client directly on the Controller application server (Windows 2012 R2) itself. For example, if you used a Windows 7 client device (connecting to the same application server) then the reports worked OK.

Diagnosing The Problem

In one real-life example, the server had recently been upgraded from Controller 10.1.1 to 10.2. However, when the user launches Cognos Connection (http://servername/ibmcognos) the 'splashscreen' still showed Cognos 10.1.1 BI being installed/used.

Resolving The Problem

Fix:
Modify the 'bad' user's Internet Explorer to re-check all of its cache files.

  • Specifically Modify the setting 'Check for newer versions of stored pages' from the default ('Automatically') to 'Every time I visit the webpage'

Steps:
The following steps are based on IE11:
1. Launch Internet Explorer
2. Click "Tools - Internet Options"
3. Inside the tab 'General' click 'Settings'
4. Modify the setting 'Check for newer versions of stored pages' from the default ('Automatically') to 'Every time I visit the webpage':


Workaround:
Do not use Controller on the affected 'bad' device (e.g. Controller application server). Instead, run the Controller client from a different client device (e.g. end user's PC).

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21680774