Troubleshooting
Problem
When you start an IBM Rational Robot script with a CallScript statement, you get error "Unable to find script file".
Symptom
The full error message is as follows:
Script Not Exists
You also get the following message and a script command failure:
Unable to find script file

Cause
Cause #1
One or more characters in the CallScript argument mismatches the case. For example:
- CallScript("myScript")
does not open MyScript. Note the upper case M.
Possible causes why the argument is case-sensitive are:
- The operating system is case-sensitive.
- The database is case-sensitive.
DB 8.2 and 9.1 are case-sensitive databases.
The case-sensitivity, when you use a DB2 database was been identified as a product defect under APAR PK70690 and has been resolved in Rational Robot version 7.0.2.
Cause #2
The parameter of CallScript contains something else than the script name without extension. You can think of a mispelled script name or a script name with extension.
EXAMPLES
CallScript("MyScrip")
CallScript("MyScript.rec")
Diagnosing The Problem
Cause #1
To see if the operating system is case-sensitive, you verify the following registry key:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\kernel\
dword:ObCaseInsensitive
If the value equals 1, the operating system is case-insensitive.
To see if the database causes the problem, verify if CallScript is case sensitive in:
- Robot stand alone mode.
- a TestManager Microsoft Access based project.
Resolving The Problem
Cause #1
- Verify the value of the registry setting to 1 and change, if necessary.
- Upgrade to Rational Robot 7.0.2 or newer.
Cause #2
Correct the CallScript parameter. In this example, the right syntax is:
CallScript("MyScript")
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Document Information
Modified date:
16 June 2018
UID
swg21319428