IBM Support

Error occurs while importing a document in RequisitePro - Runtime Error: Protection Violation

Troubleshooting


Problem

This technote identifies a potential workaround for the error, "Runtime Error: Protection Violation," that might occur while importing a document in IBM® Rational® RequisitePro®.

Cause

The Microsoft® Word registry settings have become corrupt.

Resolving The Problem

Run a Detect and Repair of Microsoft Word 2003:


    Note: Some installations of Microsoft Word will require the Microsoft Office installation CD.

    1. Close all applications

    2. Open Word

    3. Access the Help menu and Select Detect and Repair

    4. Leave the default checkbox selected and click on the Start button

    5. When the Detect and Repair completes successfully, the problem should be resolved and you should be able to continue your work in RequisitePro


Run a Detect and Repair of Microsoft Word 2007:

  1. In Add or Remove Programs, select the Office or Word installation.
  2. Click Change.
  3. Select Repair

[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Document Properties","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21246998