IBM Support

An error occurs when accessing an 'InfoStore' data source in IBM i2 Analyze

Troubleshooting


Problem

After deploying the Web Client & Information Store, an additional data source for 'InfoStore' appears in the Analyze portal. Attempting to browse or search 'InfoStore' results in a 'ServerNotFoundException' error.

Symptom

The following extra data source is available in the Analyze portal:



The following exception occurs if trying to browse/search it:

i2.Apollo.Common.Exceptions.ServerNotFoundException
Server could not be found. 
System.ServiceModel.CommunicationException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See 
http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.40728.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer    at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
  at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
  at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result)
  at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.SearchServiceClientChannel.EndSearch(IAsyncResult result)
  at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.i2.Apollo.Services.Internal.Search.AutoGen.SearchService.EndSearch(IAsyncResult result)
  at i2.Apollo.Services.Internal.Search.AutoGen.SearchServiceClient.i2.Apollo.Services.SearchService.ISearchServiceInternals.EndSearch(IAsyncResult result)
  at i2.Apollo.Services.SearchService.SearchServiceFacade.CompleteAndMarshalSearch(ISearchServiceInternals client, IAsyncResult resultToken)
  at i2.Apollo.Services.AsynchronousCallCompleter`2.GetResponse(IAsyncResult asyncResult, TResult& successResult, Exception& failureException)
System.Net.WebException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See 
http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.40728.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer    at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state)
  at System.Net.Browser.BrowserHttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
  at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelAsyncRequest.CompleteGetResponse(IAsyncResult result)
System.Net.WebException
[HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See 
http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.40728.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer    at System.Net.Browser.BrowserHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult)
  at System.Net.Browser.BrowserHttpWebRequest.<>c__DisplayClassa.<EndGetResponse>b__9(Object sendState)
  at System.Net.Browser.AsyncHelper.<>c__DisplayClass4.<BeginOnUI>b__1(Object sendState)
 

Cause

The Information Store is not designed to accessed via the Analyze portal by design. The 'InfoStore' data source is made available in error due to an erroneous 'DataSources' value being written to

\i2analyze\deploy\wlp\usr\servers\i2analyze\apps\core.war\WEB-INF\classes\ExternalDataSources.xml 

Resolving The Problem

Remove the DataSources entry for InfoStore from ExternalDataSources.xml, and restart i2 Analyze by running the following command from the i2analyze\toolkit\scripts directory:
 
setup -t stopLiberty
setup -t startLiberty


Note that re-deploying i2 Analyze at any point will results in the erroneous entry being re-added to ExternalDataSources.xml. The entry will need to be removed, and i2 Analyze restarted following every 'deploy' command.

[{"Product":{"code":"SSXVTH","label":"i2 Analyze"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"4.0.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
i2 Analyze

Software version:
4.0.0

Operating system(s):
Windows, Linux

Document number:
266771

Modified date:
16 June 2018

UID

swg21967213